[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20211115215819.28787-1-huobean@gmail.com>
Date: Mon, 15 Nov 2021 22:58:19 +0100
From: Bean Huo <huobean@...il.com>
To: axboe@...nel.dk, linux-block@...r.kernel.org,
linux-kernel@...r.kernel.org
Cc: Bean Huo <beanhuo@...ron.com>
Subject: [PATCH] block: Use REQ_OP_WRITE instead of its integer constant 1 in op_is_write()
From: Bean Huo <beanhuo@...ron.com>
Use the enums REQ_OP_WRITE in op_is_write() to make it less maintenance
requirement and more readable
Signed-off-by: Bean Huo <beanhuo@...ron.com>
---
include/linux/blk_types.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/blk_types.h b/include/linux/blk_types.h
index fe065c394fff..5b5924a7e754 100644
--- a/include/linux/blk_types.h
+++ b/include/linux/blk_types.h
@@ -463,7 +463,7 @@ static inline void bio_set_op_attrs(struct bio *bio, unsigned op,
static inline bool op_is_write(unsigned int op)
{
- return (op & 1);
+ return (op & REQ_OP_WRITE);
}
/*
--
2.25.1
Powered by blists - more mailing lists