[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20211209120456.696879-1-sudeep.holla@arm.com>
Date: Thu, 9 Dec 2021 12:04:56 +0000
From: Sudeep Holla <sudeep.holla@....com>
To: linux-kernel@...r.kernel.org, soc@...nel.org, arm@...nel.org
Cc: Sudeep Holla <sudeep.holla@....com>,
linux-arm-kernel@...ts.infradead.org, stable@...r.kernel.org,
Pedro Batista <pedbap.g@...il.com>,
Cristian Marussi <cristian.marussi@....com>
Subject: [PATCH v2] firmware: arm_scpi: Fix string overflow in SCPI genpd driver
Without the bound checks for scpi_pd->name, it could result in the buffer
overflow when copying the SCPI device name from the corresponding device
tree node as the name string is set at maximum size of 30.
Let us fix it by using devm_kasprintf so that the string buffer is
allocated dynamically.
Cc: stable@...r.kernel.org
Fixes: 8bec4337ad40 ("firmware: scpi: add device power domain support using genpd")
Reported-by: Pedro Batista <pedbap.g@...il.com>
Cc: Cristian Marussi <cristian.marussi@....com>
Signed-off-by: Sudeep Holla <sudeep.holla@....com>
---
drivers/firmware/scpi_pm_domain.c | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)
Hi ARM SoC team,
Can you apply this directly as I don't have any other fix at the moment.
Regards,
Sudeep
v1->v2:
- Fixed accidentally dropped '.' in the name
- Used devm_kasprintf instead of combination of kasprintf and
devm_kstrdup
v1: https://lore.kernel.org/r/20211206153150.565685-1-sudeep.holla@arm.com/
diff --git a/drivers/firmware/scpi_pm_domain.c b/drivers/firmware/scpi_pm_domain.c
index 51201600d789..800673910b51 100644
--- a/drivers/firmware/scpi_pm_domain.c
+++ b/drivers/firmware/scpi_pm_domain.c
@@ -16,7 +16,6 @@ struct scpi_pm_domain {
struct generic_pm_domain genpd;
struct scpi_ops *ops;
u32 domain;
- char name[30];
};
/*
@@ -110,8 +109,13 @@ static int scpi_pm_domain_probe(struct platform_device *pdev)
scpi_pd->domain = i;
scpi_pd->ops = scpi_ops;
- sprintf(scpi_pd->name, "%pOFn.%d", np, i);
- scpi_pd->genpd.name = scpi_pd->name;
+ scpi_pd->genpd.name = devm_kasprintf(dev, GFP_KERNEL,
+ "%pOFn.%d", np, i);
+ if (!scpi_pd->genpd.name) {
+ dev_err(dev, "Failed to allocate genpd name:%pOFn.%d\n",
+ np, i);
+ continue;
+ }
scpi_pd->genpd.power_off = scpi_pd_power_off;
scpi_pd->genpd.power_on = scpi_pd_power_on;
--
2.25.1
Powered by blists - more mailing lists