lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <a049118e-888b-991b-8df8-640c828b4e08@gmail.com>
Date:   Thu, 13 Jan 2022 00:11:43 +0000
From:   "Colin King (gmail)" <colin.i.king@...il.com>
To:     Damien Le Moal <damien.lemoal@...nsource.wdc.com>,
        linux-ide@...r.kernel.org
Cc:     kernel-janitors@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] ata: pata_ali: remove redundant return statement

On 12/01/2022 23:52, Damien Le Moal wrote:
> On 1/13/22 08:47, Colin Ian King wrote:
>> A return statement is unnecessarily complicated, currently value
>> in variable mask is bitwise-masked and the variable is being
>> updated and then returned. Just updating the mask is all that is
>> required as the following statement is a return.
>>
>> Signed-off-by: Colin Ian King <colin.i.king@...il.com>
>> ---
>>   drivers/ata/pata_ali.c | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/ata/pata_ali.c b/drivers/ata/pata_ali.c
>> index ab28a6707b94..1b90cda27246 100644
>> --- a/drivers/ata/pata_ali.c
>> +++ b/drivers/ata/pata_ali.c
>> @@ -123,7 +123,7 @@ static unsigned long ali_20_filter(struct ata_device *adev, unsigned long mask)
>>   		mask &= ~(ATA_MASK_MWDMA | ATA_MASK_UDMA);
>>   	ata_id_c_string(adev->id, model_num, ATA_ID_PROD, sizeof(model_num));
>>   	if (strstr(model_num, "WDC"))
>> -		return mask &= ~ATA_MASK_UDMA;
> 
> Yeah, not to mention that is really ugly as the return should really
> have been:
> 
> return mask & ~ATA_MASK_UDMA;

Yep, I did think of that as the original intention, but two return 
statements one after the other was equally as ugly. It was a 50/50 
choice of what was perceived as the better fix :-)

> 
>> +		mask &= ~ATA_MASK_UDMA;
>>   	return mask;
>>   }
>>   
> 
> Will queue this up.
> 
Thank you.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ