[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20220120113748.26602-1-idryomov@gmail.com>
Date: Thu, 20 Jan 2022 12:37:48 +0100
From: Ilya Dryomov <idryomov@...il.com>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: ceph-devel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: [GIT PULL] Ceph updates for 5.17-rc1
Hi Linus,
The following changes since commit df0cc57e057f18e44dac8e6c18aba47ab53202f9:
Linux 5.16 (2022-01-09 14:55:34 -0800)
are available in the Git repository at:
https://github.com/ceph/ceph-client.git tags/ceph-for-5.17-rc1
for you to fetch changes up to a0b3a15eab6bc2e90008460b646d53e7d9dcdbbb:
ceph: move CEPH_SUPER_MAGIC definition to magic.h (2022-01-13 13:40:07 +0100)
There is a trivial conflict caused by removal of ceph_kvmalloc()
helper that went though the akpm tree. I pushed the resolution to
for-linus-merged just in case.
----------------------------------------------------------------
The highlight is the new mount "device" string syntax implemented
by Venky Shankar. It solves some long-standing issues with using
different auth entities and/or mounting different CephFS filesystems
from the same cluster, remounting and also misleading /proc/mounts
contents. The existing syntax of course remains to be maintained.
On top of that, there is a couple of fixes for edge cases in quota
and a new mount option for turning on unbuffered I/O mode globally
instead of on a per-file basis with ioctl(CEPH_IOC_SYNCIO).
----------------------------------------------------------------
Colin Ian King (1):
rbd: make const pointer spaces a static const array
Jeff Layton (4):
ceph: drop send metrics debug message
ceph: don't check for quotas on MDS stray dirs
ceph: add new "nopagecache" option
ceph: move CEPH_SUPER_MAGIC definition to magic.h
Kotresh HR (1):
ceph: Fix incorrect statfs report for small quota
Venky Shankar (6):
libceph: generalize addr/ip parsing based on delimiter
libceph: rename parse_fsid() to ceph_parse_fsid() and export
ceph: new device mount syntax
ceph: record updated mon_addr on remount
doc: document new CephFS mount device syntax
ceph: mount syntax module parameter
Xiubo Li (1):
ceph: remove redundant Lsx caps check
Documentation/filesystems/ceph.rst | 25 +++++-
drivers/block/rbd.c | 5 +-
fs/ceph/caps.c | 3 +-
fs/ceph/file.c | 24 ++++--
fs/ceph/metric.c | 2 -
fs/ceph/quota.c | 17 ++++
fs/ceph/super.c | 169 ++++++++++++++++++++++++++++++++++---
fs/ceph/super.h | 28 +++---
include/linux/ceph/libceph.h | 3 +-
include/linux/ceph/messenger.h | 2 +-
include/uapi/linux/magic.h | 1 +
net/ceph/ceph_common.c | 18 ++--
net/ceph/messenger.c | 15 ++--
13 files changed, 255 insertions(+), 57 deletions(-)
Powered by blists - more mailing lists