[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <84f4a761263444c2940165dc403afb33@AcuMS.aculab.com>
Date: Wed, 16 Feb 2022 10:01:18 +0000
From: David Laight <David.Laight@...LAB.COM>
To: 'Phillip Potter' <phil@...lpotter.co.uk>,
"gregkh@...uxfoundation.org" <gregkh@...uxfoundation.org>
CC: "dan.carpenter@...cle.com" <dan.carpenter@...cle.com>,
"Larry.Finger@...inger.net" <Larry.Finger@...inger.net>,
"straube.linux@...il.com" <straube.linux@...il.com>,
"martin@...ser.cx" <martin@...ser.cx>,
"linux-staging@...ts.linux.dev" <linux-staging@...ts.linux.dev>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"paskripkin@...il.com" <paskripkin@...il.com>
Subject: RE: [PATCH v2 15/15] staging: r8188eu: correct long line warnings
near prior DBG_88E calls
From: Phillip Potter
> Sent: 16 February 2022 01:07
>
> Where it is possible (without out-of-patch-series-scope large scale
> refactoring), correct code to remove checkpatch warnings about lines
> that are too long, also correcting operator spacing where appropriate
> for these lines as well. These warnings occur mostly due to so many
> DBG_88E removals and parentheses tweaks etc. being adjacent to such
> long lines, which are therefore included in the resultant diff.
...
Somewhere my copy of this seems to have got its tabs deleted.
I blame outlook :-)
> diff --git a/drivers/staging/r8188eu/core/rtw_br_ext.c b/drivers/staging/r8188eu/core/rtw_br_ext.c
> index ddc3a2c8aaca..d68611ef22f8 100644
> --- a/drivers/staging/r8188eu/core/rtw_br_ext.c
> +++ b/drivers/staging/r8188eu/core/rtw_br_ext.c
> @@ -382,7 +382,7 @@ int nat25_db_handle(struct adapter *priv, struct sk_buff *skb, int method)
> if (protocol == ETH_P_IP) {
> struct iphdr *iph = (struct iphdr *)(skb->data + ETH_HLEN);
>
> -if (((unsigned char *)(iph) + (iph->ihl<<2)) >= (skb->data + ETH_HLEN + skb->len))
> +if (((unsigned char *)(iph) + (iph->ihl << 2)) >= (skb->data + ETH_HLEN + skb->len))
You can delete at least three sets of () from that line.
> return -1;
>
> switch (method) {
> @@ -451,7 +451,11 @@ int nat25_db_handle(struct adapter *priv, struct sk_buff *skb, int method)
> pOldTag = (struct pppoe_tag *)__nat25_find_pppoe_tag(ph, ntohs(PTT_RELAY_SID));
> if (pOldTag) { /* if SID existed, copy old value and delete it */
> old_tag_len = ntohs(pOldTag->tag_len);
> -if (old_tag_len+TAG_HDR_LEN+MAGIC_CODE_LEN+RTL_RELAY_TAG_LEN > sizeof(tag_buf))
> +if (old_tag_len +
> + TAG_HDR_LEN +
> + MAGIC_CODE_LEN +
> + RTL_RELAY_TAG_LEN >
> + sizeof(tag_buf))
> return -1;
That change really doesn't help readability at all.
There isn't much point shortening it that much like that, especially
since the here is a line that is nearly as long just above.
The real fix is to reduce the number of levels of indentation
to something sane.
I suspect that use of continue, break and return will help.
The other line length changes have much the same problem
but not as sever.
David
-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)
Powered by blists - more mailing lists