[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <BN9PR11MB5483BC7EE52A47CEAEFC58A0E3379@BN9PR11MB5483.namprd11.prod.outlook.com>
Date: Fri, 18 Feb 2022 09:03:22 +0000
From: "Zhang, Tianfei" <tianfei.zhang@...el.com>
To: Tom Rix <trix@...hat.com>, "Wu, Hao" <hao.wu@...el.com>,
"mdf@...nel.org" <mdf@...nel.org>,
"Xu, Yilun" <yilun.xu@...el.com>,
"linux-fpga@...r.kernel.org" <linux-fpga@...r.kernel.org>,
"linux-doc@...r.kernel.org" <linux-doc@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
CC: "corbet@....net" <corbet@....net>,
Matthew Gerlach <matthew.gerlach@...ux.intel.com>
Subject: RE: [PATCH v1 7/7] fpga: dfl: pci: Add generic OFS PCI PID
> -----Original Message-----
> From: Tom Rix <trix@...hat.com>
> Sent: Wednesday, February 16, 2022 12:16 AM
> To: Zhang, Tianfei <tianfei.zhang@...el.com>; Wu, Hao <hao.wu@...el.com>;
> mdf@...nel.org; Xu, Yilun <yilun.xu@...el.com>; linux-fpga@...r.kernel.org;
> linux-doc@...r.kernel.org; linux-kernel@...r.kernel.org
> Cc: corbet@....net; Matthew Gerlach <matthew.gerlach@...ux.intel.com>
> Subject: Re: [PATCH v1 7/7] fpga: dfl: pci: Add generic OFS PCI PID
>
>
> On 2/14/22 3:26 AM, Tianfei zhang wrote:
> > From: Matthew Gerlach <matthew.gerlach@...ux.intel.com>
> >
> > Add the PCI product id for an Open FPGA Stack PCI card.
> Is there a URL to the card ?
This PCIe Device IDs have registered by Intel.
> >
> > Signed-off-by: Matthew Gerlach <matthew.gerlach@...ux.intel.com>
> > Signed-off-by: Tianfei Zhang <tianfei.zhang@...el.com>
> > ---
> > drivers/fpga/dfl-pci.c | 4 ++++
> > 1 file changed, 4 insertions(+)
> >
> > diff --git a/drivers/fpga/dfl-pci.c b/drivers/fpga/dfl-pci.c index
> > 83b604d6dbe6..cb2fbf3eb918 100644
> > --- a/drivers/fpga/dfl-pci.c
> > +++ b/drivers/fpga/dfl-pci.c
> > @@ -76,12 +76,14 @@ static void cci_pci_free_irq(struct pci_dev *pcidev)
> > #define PCIE_DEVICE_ID_INTEL_PAC_D5005 0x0B2B
> > #define PCIE_DEVICE_ID_SILICOM_PAC_N5010 0x1000
> > #define PCIE_DEVICE_ID_SILICOM_PAC_N5011 0x1001
> > +#define PCIE_DEVICE_ID_INTEL_OFS 0xbcce
>
> INTEL_OFS is a generic name, pci id's map to specific cards
>
> Is there a more specific name for this card ?
I think using INTEL_OFS is better, because INTEL_OFS is the Generic development platform can support multiple cards which using OFS specification,
like Intel PAC N6000 card.
>
> Tom
>
> >
> > /* VF Device */
> > #define PCIE_DEVICE_ID_VF_INT_5_X 0xBCBF
> > #define PCIE_DEVICE_ID_VF_INT_6_X 0xBCC1
> > #define PCIE_DEVICE_ID_VF_DSC_1_X 0x09C5
> > #define PCIE_DEVICE_ID_INTEL_PAC_D5005_VF 0x0B2C
> > +#define PCIE_DEVICE_ID_INTEL_OFS_VF 0xbccf
> >
> > static struct pci_device_id cci_pcie_id_tbl[] = {
> > {PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCIE_DEVICE_ID_PF_INT_5_X),},
> @@
> > -95,6 +97,8 @@ static struct pci_device_id cci_pcie_id_tbl[] = {
> > {PCI_DEVICE(PCI_VENDOR_ID_INTEL,
> PCIE_DEVICE_ID_INTEL_PAC_D5005_VF),},
> > {PCI_DEVICE(PCI_VENDOR_ID_SILICOM_DENMARK,
> PCIE_DEVICE_ID_SILICOM_PAC_N5010),},
> > {PCI_DEVICE(PCI_VENDOR_ID_SILICOM_DENMARK,
> > PCIE_DEVICE_ID_SILICOM_PAC_N5011),},
> > + {PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCIE_DEVICE_ID_INTEL_OFS),},
> > + {PCI_DEVICE(PCI_VENDOR_ID_INTEL,
> PCIE_DEVICE_ID_INTEL_OFS_VF),},
> > {0,}
> > };
> > MODULE_DEVICE_TABLE(pci, cci_pcie_id_tbl);
Powered by blists - more mailing lists