[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <9cb7c909-eded-4933-c7a5-a7aa5a5221da@redhat.com>
Date: Mon, 14 Mar 2022 14:12:10 +0100
From: David Hildenbrand <david@...hat.com>
To: Miaohe Lin <linmiaohe@...wei.com>, akpm@...ux-foundation.org
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mm/mremap:: Use vma_lookup() instead of find_vma()
On 12.03.22 09:31, Miaohe Lin wrote:
> Using vma_lookup() verifies the address is contained in the found vma.
> This results in easier to read the code.
>
> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
> ---
> mm/mremap.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/mm/mremap.c b/mm/mremap.c
> index 002eec83e91e..9d76da79594d 100644
> --- a/mm/mremap.c
> +++ b/mm/mremap.c
> @@ -942,8 +942,8 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
>
> if (mmap_write_lock_killable(current->mm))
> return -EINTR;
> - vma = find_vma(mm, addr);
> - if (!vma || vma->vm_start > addr) {
> + vma = vma_lookup(mm, addr);
> + if (!vma) {
> ret = EFAULT;
> goto out;
> }
Reviewed-by: David Hildenbrand <david@...hat.com>
--
Thanks,
David / dhildenb
Powered by blists - more mailing lists