[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220608150142.nnhiyp5svrrkenxv@gator>
Date: Wed, 8 Jun 2022 17:01:42 +0200
From: Andrew Jones <drjones@...hat.com>
To: Sean Christopherson <seanjc@...gle.com>
Cc: Paolo Bonzini <pbonzini@...hat.com>, kvm@...r.kernel.org,
Vitaly Kuznetsov <vkuznets@...hat.com>,
David Matlack <dmatlack@...gle.com>,
Ben Gardon <bgardon@...gle.com>,
Oliver Upton <oupton@...gle.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 045/144] KVM: selftests: Make vm_create() a wrapper
that specifies VM_MODE_DEFAULT
On Fri, Jun 03, 2022 at 12:41:52AM +0000, Sean Christopherson wrote:
...
> +/*
> + * ____vm_create() does KVM_CREATE_VM and little else. __vm_create() also
> + * loads the test binary into guest memory and creates an IRQ chip (x86 only).
> + */
> +struct kvm_vm *____vm_create(enum vm_guest_mode mode, uint64_t nr_pages);
> +struct kvm_vm *__vm_create(enum vm_guest_mode mode, uint64_t nr_pages);
> +
> static inline struct kvm_vm *vm_create_barebones(void)
> {
> - return __vm_create(VM_MODE_DEFAULT, 0);
> + return ____vm_create(VM_MODE_DEFAULT, 0);
> +}
> +
I don't [overly] mind the "____helperhelper" naming style, but in this
case wouldn't __vm_create_barebones() also be a reasonable name?
Thanks,
drew
Powered by blists - more mailing lists