[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAJZ5v0g3pHDNkVu6YqANO7yM4s_CPih0nBXcgz3OBmrRSjLh2A@mail.gmail.com>
Date: Fri, 10 Jun 2022 15:40:23 +0200
From: "Rafael J. Wysocki" <rafael@...nel.org>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Mark Brown <broonie@...nel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
linux-spi <linux-spi@...r.kernel.org>,
"Rafael J. Wysocki" <rafael@...nel.org>
Subject: Re: [PATCH v2 1/2] driver core: Introduce device_find_any_child() helper
On Fri, Jun 10, 2022 at 2:02 PM Andy Shevchenko
<andriy.shevchenko@...ux.intel.com> wrote:
>
> There are several places in the kernel where this kind of functionality is
> being used. Provide a generic helper for such cases.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
> ---
> v2: renamed method (Greg), refactored it (Rafael)
> drivers/base/core.c | 20 ++++++++++++++++++++
> include/linux/device.h | 2 ++
> 2 files changed, 22 insertions(+)
>
> diff --git a/drivers/base/core.c b/drivers/base/core.c
> index 7cd789c4985d..a519307fda60 100644
> --- a/drivers/base/core.c
> +++ b/drivers/base/core.c
> @@ -3832,6 +3832,26 @@ struct device *device_find_child_by_name(struct device *parent,
> }
> EXPORT_SYMBOL_GPL(device_find_child_by_name);
>
> +static int match_any(struct device *dev, void *unused)
> +{
> + return 1;
> +}
> +
> +/**
> + * device_find_any_child - device iterator for locating a child device, if any.
> + * @parent: parent struct device
> + *
> + * This is similar to the device_find_child() function above, but it
> + * returns a reference to a child device, if any.
> + *
> + * NOTE: you will need to drop the reference with put_device() after use.
> + */
> +struct device *device_find_any_child(struct device *parent)
> +{
> + return device_find_child(parent, NULL, match_any);
> +}
> +EXPORT_SYMBOL_GPL(device_find_any_child);
I would call it device_get_any_child() to indicate the reference
counting, but that's a very minor nit.
Regardless of the above
Reviewed-by: Rafael J. Wysocki <rafael.j.wysocki@...el.com>
> +
> int __init devices_init(void)
> {
> devices_kset = kset_create_and_add("devices", &device_uevent_ops, NULL);
> diff --git a/include/linux/device.h b/include/linux/device.h
> index dc941997795c..424b55df0272 100644
> --- a/include/linux/device.h
> +++ b/include/linux/device.h
> @@ -905,6 +905,8 @@ struct device *device_find_child(struct device *dev, void *data,
> int (*match)(struct device *dev, void *data));
> struct device *device_find_child_by_name(struct device *parent,
> const char *name);
> +struct device *device_find_any_child(struct device *parent);
> +
> int device_rename(struct device *dev, const char *new_name);
> int device_move(struct device *dev, struct device *new_parent,
> enum dpm_order dpm_order);
> --
> 2.35.1
>
Powered by blists - more mailing lists