[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220816211832.6elmi3sg5gaeh3jl@halaneylaptop>
Date: Tue, 16 Aug 2022 16:18:32 -0500
From: Andrew Halaney <ahalaney@...hat.com>
To: Abel Vesa <abel.vesa@...aro.org>
Cc: Srinivas Kandagatla <srinivas.kandagatla@...aro.org>,
Amol Maheshwari <amahesh@....qualcomm.com>,
Arnd Bergmann <arnd@...db.de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-arm-msm@...r.kernel.org,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] misc: fastrpc: Use USER_PD define in
fastrpc_get_info_from_dsp
On Tue, Aug 16, 2022 at 01:55:28PM +0300, Abel Vesa wrote:
> There are defines for each type of protection domain now.
> Use the USER_PD instead of magic value in fastrpc_get_info_from_dsp.
>
> Signed-off-by: Abel Vesa <abel.vesa@...aro.org>
> Cc: Srinivas Kandagatla <srinivas.kandagatla@...aro.org>
> Cc: Amol Maheshwari <amahesh@....qualcomm.com>
This looks like it got the only remaining magic value assignment.
Reviewed-by: Andrew Halaney <ahalaney@...hat.com>
> ---
> drivers/misc/fastrpc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/misc/fastrpc.c b/drivers/misc/fastrpc.c
> index 93ebd174d848..8895ca593911 100644
> --- a/drivers/misc/fastrpc.c
> +++ b/drivers/misc/fastrpc.c
> @@ -1515,7 +1515,7 @@ static int fastrpc_get_info_from_dsp(struct fastrpc_user *fl, uint32_t *dsp_attr
> args[1].ptr = (u64)(uintptr_t)&dsp_attr_buf[1];
> args[1].length = dsp_attr_buf_len;
> args[1].fd = -1;
> - fl->pd = 1;
> + fl->pd = USER_PD;
>
> return fastrpc_internal_invoke(fl, true, FASTRPC_DSP_UTILITIES_HANDLE,
> FASTRPC_SCALARS(0, 1, 1), args);
> --
> 2.34.1
>
Powered by blists - more mailing lists