[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <f3fca555-9a66-2028-0435-1a8b41eec95c@linaro.org>
Date: Wed, 17 Aug 2022 12:08:57 +0100
From: Srinivas Kandagatla <srinivas.kandagatla@...aro.org>
To: Abel Vesa <abel.vesa@...aro.org>,
Amol Maheshwari <amahesh@....qualcomm.com>,
Arnd Bergmann <arnd@...db.de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc: linux-arm-msm@...r.kernel.org,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] misc: fastrpc: Use USER_PD define in
fastrpc_get_info_from_dsp
On 16/08/2022 11:55, Abel Vesa wrote:
> There are defines for each type of protection domain now.
> Use the USER_PD instead of magic value in fastrpc_get_info_from_dsp.
>
> Signed-off-by: Abel Vesa <abel.vesa@...aro.org>
> Cc: Srinivas Kandagatla <srinivas.kandagatla@...aro.org>
> Cc: Amol Maheshwari <amahesh@....qualcomm.com>
> ---
LGTM
Reviewed-by: Srinivas Kandagatla <srinivas.kandagatla@...aro.org>
--srini
> drivers/misc/fastrpc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/misc/fastrpc.c b/drivers/misc/fastrpc.c
> index 93ebd174d848..8895ca593911 100644
> --- a/drivers/misc/fastrpc.c
> +++ b/drivers/misc/fastrpc.c
> @@ -1515,7 +1515,7 @@ static int fastrpc_get_info_from_dsp(struct fastrpc_user *fl, uint32_t *dsp_attr
> args[1].ptr = (u64)(uintptr_t)&dsp_attr_buf[1];
> args[1].length = dsp_attr_buf_len;
> args[1].fd = -1;
> - fl->pd = 1;
> + fl->pd = USER_PD;
>
> return fastrpc_internal_invoke(fl, true, FASTRPC_DSP_UTILITIES_HANDLE,
> FASTRPC_SCALARS(0, 1, 1), args);
Powered by blists - more mailing lists