[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YwXkuW3rSYY7ZJT+@zn.tnic>
Date: Wed, 24 Aug 2022 10:43:37 +0200
From: Borislav Petkov <bp@...en8.de>
To: Vincent MAILHOL <mailhol.vincent@...adoo.fr>
Cc: Nick Desaulniers <ndesaulniers@...gle.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, x86@...nel.org,
Peter Zijlstra <peterz@...radead.org>,
Dave Hansen <dave.hansen@...ux.intel.com>,
"H . Peter Anvin" <hpa@...or.com>,
Nathan Chancellor <nathan@...nel.org>,
Tom Rix <trix@...hat.com>, linux-kernel@...r.kernel.org,
llvm@...ts.linux.dev, David Howells <dhowells@...hat.com>,
Jan Beulich <JBeulich@...e.com>,
Christophe Jaillet <christophe.jaillet@...adoo.fr>,
Joe Perches <joe@...ches.com>,
Josh Poimboeuf <jpoimboe@...nel.org>
Subject: Re: [PATCH v5 2/2] x86/asm/bitops: __ffs,ffz: use __builtin_ctzl to
evaluate constant expressions
On Wed, Aug 24, 2022 at 05:31:20AM +0900, Vincent MAILHOL wrote:
> If the fact that __ffs(0) is undefined is a concern,
So what is of concern is I'm looking at those *ffs things and they look
like a real mess:
* Undefined if no bit exists, so code should check against 0 first.
*/
static __always_inline unsigned long __ffs(unsigned long word)
{
asm("rep; bsf %1,%0"
and that's TZCNT.
And nowhere in TZCNT's description does it talk about undefined behavior
- it is all defined.
So I have no clue what that comment is supposed to mean?
Then:
* ffs - find first set bit in word
* @x: the word to search
*
* This is defined the same way as the libc and compiler builtin ffs
* routines, therefore differs in spirit from the other bitops.
*
* ffs(value) returns 0 if value is 0 or the position of the first
* set bit if value is nonzero. The first (least significant) bit
* is at position 1.
while
"Built-in Function: int __builtin_ctz (unsigned int x)
Returns the number of trailing 0-bits in x, starting at the least significant bit position. If x is 0, the result is undefined."
as previously pasted.
So ffs() doesn't have undefined behavior either.
I guess it wants to say, it is undefined in the *respective* libc or
compiler helper implementation. And that should be explained.
> I can add a safety net:
Nah, no need. It seems this "behavior" has been the case a long time so
callers should know better (or have burned themselves properly :)).
> There is an index issue. __ffs() starts at 0 but ffs() starts at one.
> i.e.: __ffs(0x01) is 0 but ffs(0x01) is 1.
> Aside from the zero edge case, ffs(x) equals __ffs(x) + 1. This
> explains why __fss(0) is undefined.
I'd love to drop the undefined thing and start counting at 1 while
keeping the 0 case the special one.
But that ship has sailed a long time ago - look at all the __ffs() and
ffs() callers.
Back to your patch: I think the text should be fixed to say that both
ffs() and __ffs()'s kernel implementation doesn't have undefined results
but since it needs to adhere to the libc variants' API, it treats 0
differently. They surely can handle 0 as input.
I.e., I'd like to see a comment there explaining the whole difference
between ffs() and __ffs() so that people are aware.
Btw, pls do
s/variable___ffs/variable__ffs/g
Two underscores are just fine.
Thx.
--
Regards/Gruss,
Boris.
https://people.kernel.org/tglx/notes-about-netiquette
Powered by blists - more mailing lists