[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <408fbc89-8711-0ea2-16e7-99b746e1f09e@linux.alibaba.com>
Date: Thu, 15 Sep 2022 10:44:37 +0800
From: haoxin <xhao@...ux.alibaba.com>
To: Al Viro <viro@...iv.linux.org.uk>
Cc: akpm@...ux-foundation.org, linux-mm@...ck.org,
linux-kernel@...r.kernel.org, mike.kravetz@...cle.com,
songmuchun@...edance.com, SeongJae Park <sj@...nel.org>
Subject: Re: [PATCH] mm/hugetlbfs: use macro SZ_1K to replace 1024
在 2022/9/15 上午12:43, Al Viro 写道:
> On Wed, Sep 14, 2022 at 07:57:23PM +0800, Xin Hao wrote:
>> Using macro SZ_1K in hugetlbfs_show_options() has no any functional
>> changes, just makes code more readable.
> Why is it any more readable that way?
The main purpose of this code is to convert size to 'K', and 'M'. I
think using SZ_1k does look more appropriate than 1024, that's all.
>> Signed-off-by: Xin Hao <xhao@...ux.alibaba.com>
>> ---
>> fs/hugetlbfs/inode.c | 6 +++---
>> 1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
>> index f7a5b5124d8a..9b9784ffe8de 100644
>> --- a/fs/hugetlbfs/inode.c
>> +++ b/fs/hugetlbfs/inode.c
>> @@ -1023,10 +1023,10 @@ static int hugetlbfs_show_options(struct seq_file *m, struct dentry *root)
>> if (sbinfo->max_inodes != -1)
>> seq_printf(m, ",nr_inodes=%lu", sbinfo->max_inodes);
>>
>> - hpage_size /= 1024;
>> + hpage_size /= SZ_1K;
>> mod = 'K';
>> - if (hpage_size >= 1024) {
>> - hpage_size /= 1024;
>> + if (hpage_size >= SZ_1K) {
>> + hpage_size /= SZ_1K;
>> mod = 'M';
>> }
>> seq_printf(m, ",pagesize=%lu%c", hpage_size, mod);
>> --
>> 2.31.0
Powered by blists - more mailing lists