lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 26 Sep 2022 14:37:28 +0800
From:   Jason Yan <yanaijie@...wei.com>
To:     Jinpu Wang <jinpu.wang@...os.com>
CC:     <martin.petersen@...cle.com>, <jejb@...ux.ibm.com>,
        <linux-scsi@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
        <hare@...e.com>, <hch@....de>, <bvanassche@....org>,
        <john.garry@...wei.com>
Subject: Re: [PATCH v2 0/8] scsi: libsas: sas address comparation refactor


On 2022/9/26 14:09, Jinpu Wang wrote:
> On Sat, Sep 24, 2022 at 9:24 AM Jason Yan <yanaijie@...wei.com> wrote:
>>
>> Sas address conversion and comparation is widely used in libsas and
>> drivers. However they are all opencoded and to avoid the line spill over
>> 80 columns, are mostly split into multi-lines.
>>
>> To make the code easier to read, introduce some helpers with clearer
>> semantics and replace the opencoded segments with them.
>>
>> v1->v2:
>>    First factor out sas_find_attached_phy() and replace LLDDs's code
>>          with it.
>>    Remove three too simple helpers.
>>    Rename the helpers with 'sas_' prefix.
>>
> Hi Jason,
> 
> Thx for doing this.
>> Jason Yan (8):
>>    scsi: libsas: introduce sas_find_attached_phy() helper
>>    scsi: pm8001: use sas_find_attached_phy() instead of open coded
>>    scsi: mvsas: use sas_find_attached_phy() instead of open coded
>>    scsi: hisi_sas: use sas_find_attathed_phy() instead of open coded
> These 4 look good to me.
> Reviewed-by: Jack Wang <jinpu.wang@...os.com>

Hi Jack,
Thank you very much for the review.

>>    scsi: libsas: introduce sas address comparation helpers
>>    scsi: libsas: use sas_phy_match_dev_addr() instead of open coded
>>    scsi: libsas: use sas_phy_addr_same() instead of open coded
>>    scsi: libsas: use sas_phy_match_port_addr() instead of open coded
> These helpers are too simple to replace, we add more loc in the end.

The initial purpose to introduce these helpers is to stop cutting 
compare expressions into two lines and to make the code looks clean. We 
add more loc in the end because of function declaration and more blank 
lines between them.

Thanks,
Jason

>>
>>   drivers/scsi/hisi_sas/hisi_sas_main.c | 12 ++------
>>   drivers/scsi/libsas/sas_expander.c    | 40 ++++++++++++++++-----------
>>   drivers/scsi/libsas/sas_internal.h    | 17 ++++++++++++
>>   drivers/scsi/mvsas/mv_sas.c           | 15 +++-------
>>   drivers/scsi/pm8001/pm8001_sas.c      | 16 ++++-------
>>   include/scsi/libsas.h                 |  2 ++
>>   6 files changed, 54 insertions(+), 48 deletions(-)
>>
>> --
>> 2.31.1
>>
> .
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ