[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20221001001831.46355-1-postmaster@gusted.xyz>
Date: Sat, 1 Oct 2022 02:18:31 +0200
From: William Zijl <postmaster@...ted.xyz>
To: Jason@...c4.com
Cc: tytso@....edu, linux-kernel@...r.kernel.org,
William Zijl <postmaster@...ted.xyz>
Subject: [PATCH] Improve comment of get_random_bytes function
The old comment of this function had a double whitespace and contained
grammatical errors, such as: `the randomness by this function`, `at
least once at any point prior`. This patch replaces those sentenced with
`the randomness of this function`, `at any point prior to this`
respectively.
Signed-off-by: William Zijl <postmaster@...ted.xyz>
---
drivers/char/random.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/char/random.c b/drivers/char/random.c
index 64ee16ffb8b7..e0b1b31789a5 100644
--- a/drivers/char/random.c
+++ b/drivers/char/random.c
@@ -382,11 +382,11 @@ static void _get_random_bytes(void *buf, size_t len)
}
/*
- * This function is the exported kernel interface. It returns some
- * number of good random numbers, suitable for key generation, seeding
- * TCP sequence numbers, etc. In order to ensure that the randomness
- * by this function is okay, the function wait_for_random_bytes()
- * should be called and return 0 at least once at any point prior.
+ * This function is the exported kernel interface. It returns some number
+ * of good random numbers, suitable for key generation, seeding TCP
+ * sequence numbers, etc. In order to ensure that the randomness of this
+ * function is okay, the function wait_for_random_bytes() should be called
+ * and return 0 at least once at any point prior to this.
*/
void get_random_bytes(void *buf, size_t len)
{
--
2.37.3
Powered by blists - more mailing lists