[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <874jvzdu4f.fsf@linux.ibm.com>
Date: Thu, 20 Oct 2022 09:27:52 +0530
From: "Aneesh Kumar K.V" <aneesh.kumar@...ux.ibm.com>
To: Huang Ying <ying.huang@...el.com>, linux-mm@...ck.org
Cc: linux-kernel@...r.kernel.org,
Andrew Morton <akpm@...ux-foundation.org>,
Huang Ying <ying.huang@...el.com>,
Alistair Popple <apopple@...dia.com>,
Bharata B Rao <bharata@....com>,
Dan Williams <dan.j.williams@...el.com>,
Dave Hansen <dave.hansen@...el.com>,
Davidlohr Bueso <dave@...olabs.net>,
Hesham Almatary <hesham.almatary@...wei.com>,
Jagdish Gediya <jvgediya.oss@...il.com>,
Johannes Weiner <hannes@...xchg.org>,
Jonathan Cameron <Jonathan.Cameron@...wei.com>,
Michal Hocko <mhocko@...nel.org>,
Tim Chen <tim.c.chen@...el.com>, Wei Xu <weixugc@...gle.com>,
Yang Shi <shy828301@...il.com>
Subject: Re: [PATCH] memory tier, sysfs: rename attribute "nodes" to "nodelist"
Huang Ying <ying.huang@...el.com> writes:
> In sysfs, we use attribute name "cpumap" or "cpus" for cpu mask and
> "cpulist" or "cpus_list" for cpu list. For example, in my system,
>
> $ cat /sys/devices/system/node/node0/cpumap
> f,ffffffff
> $ cat /sys/devices/system/cpu/cpu2/topology/core_cpus
> 0,00100004
> $ cat cat /sys/devices/system/node/node0/cpulist
> 0-35
> $ cat /sys/devices/system/cpu/cpu2/topology/core_cpus_list
> 2,20
>
> It looks reasonable to use "nodemap" for node mask and "nodelist" for
> node list. So, rename the attribute to follow the naming convention.
>
Reviewed-by: Aneesh Kumar K.V <aneesh.kumar@...ux.ibm.com>
> Signed-off-by: "Huang, Ying" <ying.huang@...el.com>
> Cc: Aneesh Kumar K.V <aneesh.kumar@...ux.ibm.com>
> Cc: Alistair Popple <apopple@...dia.com>
> Cc: Bharata B Rao <bharata@....com>
> Cc: Dan Williams <dan.j.williams@...el.com>
> Cc: Dave Hansen <dave.hansen@...el.com>
> Cc: Davidlohr Bueso <dave@...olabs.net>
> Cc: Hesham Almatary <hesham.almatary@...wei.com>
> Cc: Jagdish Gediya <jvgediya.oss@...il.com>
> Cc: Johannes Weiner <hannes@...xchg.org>
> Cc: Jonathan Cameron <Jonathan.Cameron@...wei.com>
> Cc: Michal Hocko <mhocko@...nel.org>
> Cc: Tim Chen <tim.c.chen@...el.com>
> Cc: Wei Xu <weixugc@...gle.com>
> Cc: Yang Shi <shy828301@...il.com>
> ---
> Documentation/ABI/testing/sysfs-kernel-mm-memory-tiers | 4 ++--
> mm/memory-tiers.c | 8 ++++----
> 2 files changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/Documentation/ABI/testing/sysfs-kernel-mm-memory-tiers b/Documentation/ABI/testing/sysfs-kernel-mm-memory-tiers
> index 45985e411f13..721a05b90109 100644
> --- a/Documentation/ABI/testing/sysfs-kernel-mm-memory-tiers
> +++ b/Documentation/ABI/testing/sysfs-kernel-mm-memory-tiers
> @@ -10,7 +10,7 @@ Description: A collection of all the memory tiers allocated.
>
>
> What: /sys/devices/virtual/memory_tiering/memory_tierN/
> - /sys/devices/virtual/memory_tiering/memory_tierN/nodes
> + /sys/devices/virtual/memory_tiering/memory_tierN/nodelist
> Date: August 2022
> Contact: Linux memory management mailing list <linux-mm@...ck.org>
> Description: Directory with details of a specific memory tier
> @@ -21,5 +21,5 @@ Description: Directory with details of a specific memory tier
> A smaller value of N implies a higher (faster) memory tier in the
> hierarchy.
>
> - nodes: NUMA nodes that are part of this memory tier.
> + nodelist: NUMA nodes that are part of this memory tier.
>
> diff --git a/mm/memory-tiers.c b/mm/memory-tiers.c
> index f116b7b6333e..fa8c9d07f9ce 100644
> --- a/mm/memory-tiers.c
> +++ b/mm/memory-tiers.c
> @@ -131,8 +131,8 @@ static void memory_tier_device_release(struct device *dev)
> kfree(tier);
> }
>
> -static ssize_t nodes_show(struct device *dev,
> - struct device_attribute *attr, char *buf)
> +static ssize_t nodelist_show(struct device *dev,
> + struct device_attribute *attr, char *buf)
> {
> int ret;
> nodemask_t nmask;
> @@ -143,10 +143,10 @@ static ssize_t nodes_show(struct device *dev,
> mutex_unlock(&memory_tier_lock);
> return ret;
> }
> -static DEVICE_ATTR_RO(nodes);
> +static DEVICE_ATTR_RO(nodelist);
>
> static struct attribute *memtier_dev_attrs[] = {
> - &dev_attr_nodes.attr,
> + &dev_attr_nodelist.attr,
> NULL
> };
>
> --
> 2.35.1
Powered by blists - more mailing lists