lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 21 Oct 2022 15:26:23 +0300
From:   Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To:     Mark Brown <broonie@...nel.org>
Cc:     linux-arm-kernel@...ts.infradead.org, linux-spi@...r.kernel.org,
        linux-kernel@...r.kernel.org, Daniel Mack <daniel@...que.org>,
        Haojian Zhuang <haojian.zhuang@...il.com>,
        Robert Jarzmik <robert.jarzmik@...e.fr>
Subject: Re: [PATCH v4 1/5] spi: pxa2xx: Respect Intel SSP type given by a
 property

On Fri, Oct 21, 2022 at 01:16:01PM +0100, Mark Brown wrote:
> On Thu, Oct 20, 2022 at 10:44:56PM +0300, Andy Shevchenko wrote:
> 
> > Allow to set the Intel SSP type by reading the property.
> > Only apply this to the known MFD enumerated devices.
> 
> > +	/* For MFD enumerated devices always ask for a property */
> > +	mfd_enumerated = platform_get_resource_byname(pdev, IORESOURCE_MEM, "lpss_priv");
> > +	if (mfd_enumerated) {
> > +		status = device_property_read_u32(dev, "intel,spi-pxa2xx-type", &value);
> > +		if (status)
> > +			return ERR_PTR(status);
> > +	}
> > +
> >  	if (pcidev)
> >  		pcidev_id = pci_match_id(pxa2xx_spi_pci_compound_match, pcidev);
> >  
> >  	match = device_get_match_data(&pdev->dev);
> >  	if (match)
> >  		type = (enum pxa_ssp_type)match;
> > +	else if (value > SSP_UNDEFINED && value < SSP_MAX)
> > +		type = (enum pxa_ssp_type)value;
> 
> This is quite hard to follow, partly because value isn't exactly a clear
> variable name and partly because the initialisation to SSP_UNDEFINED,
> the attempt to read via device property and this if/else chain are split
> up and not clearly joined up with each other.  This is partly an issue
> with the existing code but the extra layer of spreading things
> throughout the function being added amplifies things a bit.

The next patch removes the PCI part in this equation, at the end there is
no "new" complexity on top of the existing one. But I'm all ears on how
to simplify the existing code.

-- 
With Best Regards,
Andy Shevchenko


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ