[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Y2q2GFWjLKMp5eUr@google.com>
Date: Tue, 8 Nov 2022 20:03:36 +0000
From: Sean Christopherson <seanjc@...gle.com>
To: Andrey Ryabinin <ryabinin.a.a@...il.com>
Cc: Dave Hansen <dave.hansen@...ux.intel.com>,
Andy Lutomirski <luto@...nel.org>,
Peter Zijlstra <peterz@...radead.org>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
x86@...nel.org, Alexander Potapenko <glider@...gle.com>,
Andrey Konovalov <andreyknvl@...il.com>,
Dmitry Vyukov <dvyukov@...gle.com>,
Vincenzo Frascino <vincenzo.frascino@....com>,
"H. Peter Anvin" <hpa@...or.com>, kasan-dev@...glegroups.com,
linux-kernel@...r.kernel.org,
syzbot+8cdd16fd5a6c0565e227@...kaller.appspotmail.com
Subject: Re: [PATCH 3/3] x86/kasan: Populate shadow for shared chunk of the
CPU entry area
On Tue, Nov 08, 2022, Andrey Ryabinin wrote:
>
> On 11/4/22 21:32, Sean Christopherson wrote:
> > @@ -409,6 +410,15 @@ void __init kasan_init(void)
> > kasan_mem_to_shadow((void *)VMALLOC_END + 1),
> > (void *)shadow_cea_begin);
> >
> > + /*
> > + * Populate the shadow for the shared portion of the CPU entry area.
> > + * Shadows for the per-CPU areas are mapped on-demand, as each CPU's
> > + * area is randomly placed somewhere in the 512GiB range and mapping
> > + * the entire 512GiB range is prohibitively expensive.
> > + */
> > + kasan_populate_shadow(shadow_cea_begin,
> > + shadow_cea_per_cpu_begin, 0);
> > +
>
> I think we can extend the kasan_populate_early_shadow() call above up to
> shadow_cea_per_cpu_begin point, instead of this.
> populate_early_shadow() maps single RO zeroed page. No one should write to the shadow for IDT.
> KASAN only needs writable shadow for linear mapping/stacks/vmalloc/global variables.
Is that the only difference between the "early" and "normal" variants? If so,
renaming them to kasan_populate_ro_shadow() vs. kasan_populate_rw_shadow() would
make this code much more intuitive for non-KASAN folks.
>
> > kasan_populate_early_shadow((void *)shadow_cea_end,
> > kasan_mem_to_shadow((void *)__START_KERNEL_map));
> >
Powered by blists - more mailing lists