[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Y4nXY05iM034z6Gi@kroah.com>
Date: Fri, 2 Dec 2022 11:45:55 +0100
From: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
To: Sakari Ailus <sakari.ailus@...ux.intel.com>
Cc: linux-kernel@...r.kernel.org, Jason Gunthorpe <jgg@...pe.ca>,
Matthew Wilcox <willy@...radead.org>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
"Rafael J. Wysocki" <rafael@...nel.org>
Subject: Re: [PATCH 1/4] container_of: add container_of_const() that
preserves const-ness of the pointer
On Thu, Dec 01, 2022 at 11:21:50PM +0000, Sakari Ailus wrote:
> Hi Greg,
>
> On Thu, Dec 01, 2022 at 08:30:54PM +0100, Greg Kroah-Hartman wrote:
> > container_of does not preserve the const-ness of a pointer that is
> > passed into it, which can cause C code that passes in a const pointer to
> > get a pointer back that is not const and then scribble all over the data
> > in it. To prevent this, container_of_const() will preserve the const
> > status of the pointer passed into it using the newly available _Generic()
> > method.
>
> "_const" in the name suggests that the macro would always take a const
> argument.
I mean it here to be "this will preserve const" as yes, it can take a
const. Or not.
> Could this be called e.g. container_of_safe() (for type-safe, but
> full type_safe would be a bit long)?
const is an attribute of type safety, container_of is also type-safe
as-is, it's just the const portion here that is the difference between
the two.
Naming is hard :(
>
> --
> Kind regards,
>
> Sakari Ailus
Powered by blists - more mailing lists