[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <BY5PR04MB6327A3C457A16BDFC5C13ADAED199@BY5PR04MB6327.namprd04.prod.outlook.com>
Date: Sun, 4 Dec 2022 13:22:43 +0000
From: Arthur Simchaev <Arthur.Simchaev@....com>
To: Arthur Simchaev <Arthur.Simchaev@....com>,
"martin.petersen@...cle.com" <martin.petersen@...cle.com>
CC: "beanhuo@...ron.com" <beanhuo@...ron.com>,
"linux-scsi@...r.kernel.org" <linux-scsi@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: RE: [PATCH v4 0/4] ufs: core: Always read the descriptors with max
length
Hi Martin,
Gentle reminder
Regards
Arthur
> -----Original Message-----
> From: Arthur Simchaev <Arthur.Simchaev@....com>
> Sent: Sunday, November 27, 2022 2:08 PM
> To: martin.petersen@...cle.com
> Cc: beanhuo@...ron.com; linux-scsi@...r.kernel.org; linux-
> kernel@...r.kernel.org; Arthur Simchaev <Arthur.Simchaev@....com>
> Subject: [PATCH v4 0/4] ufs: core: Always read the descriptors with max length
>
> v3--v4:
> Add "Reviewed-by" to patch's commits
> Use kzalloc instead of kmalloc in drivers/ufs/core/ufshcd.c - patch 2/4
>
> v2--v3:
> Based on Bean's comments:
> 1)Use kzalloc instead of kmalloc in ufshcd_set_active_icc_lvl - patch 2/4
> 2)Delete UFS_RPMB_UNIT definition - patch 2/4
> 3)Delete len description - patch 3/4
>
> v1--v2:
> Fix argument warning in ufshpb.c
>
> Read any descriptor with a maximum size of QUERY_DESC_MAX_SIZE.
> According to the spec the device rerurns the actual size.
> Thus can improve code readability and save CPU cycles.
> While at it, cleanup few leftovers around the descriptor size parameter.
>
> Suggested-by: Bean Huo <beanhuo@...ron.com>
>
> Arthur Simchaev (4):
> ufs:core: Remove redundant wb check
> ufs:core: Remove redundant desc_size variable from hba
> ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl
> ufs: core: Remove ufshcd_map_desc_id_to_length function
>
> drivers/ufs/core/ufs_bsg.c | 7 +--
> drivers/ufs/core/ufshcd-priv.h | 3 --
> drivers/ufs/core/ufshcd.c | 100 ++++++++++-------------------------------
> drivers/ufs/core/ufshpb.c | 5 +--
> include/ufs/ufshcd.h | 1 -
> 5 files changed, 26 insertions(+), 90 deletions(-)
>
> --
> 2.7.4
Powered by blists - more mailing lists