[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <Y6TM4ZidDExh8SPx@qemulion>
Date: Fri, 23 Dec 2022 03:02:17 +0530
From: Deepak R Varma <drv@...lo.com>
To: Yinbo Zhu <zhuyinbo@...ngson.cn>, loongarch@...ts.linux.dev,
linux-kernel@...r.kernel.org
Cc: Saurabh Singh Sengar <ssengar@...rosoft.com>,
Praveen Kumar <kumarpraveen@...ux.microsoft.com>, drv@...lo.com
Subject: [PATCH] soc: loongson: use resource_size() helper function
Use the resource_size() function instead of a open coded computation
resource size. It makes the code more readable.
Issue identified using resource_size.cocci coccinelle semantic patch.
Signed-off-by: Deepak R Varma <drv@...lo.com>
---
Note: Proposed change is compile tested only.
drivers/soc/loongson/loongson2_guts.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/soc/loongson/loongson2_guts.c b/drivers/soc/loongson/loongson2_guts.c
index bace4bc8e03b..aba4f8832805 100644
--- a/drivers/soc/loongson/loongson2_guts.c
+++ b/drivers/soc/loongson/loongson2_guts.c
@@ -107,7 +107,7 @@ static int loongson2_guts_probe(struct platform_device *pdev)
guts->little_endian = of_property_read_bool(np, "little-endian");
res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
- guts->regs = ioremap(res->start, res->end - res->start + 1);
+ guts->regs = ioremap(res->start, resource_size(res));
if (IS_ERR(guts->regs))
return PTR_ERR(guts->regs);
--
2.34.1
Powered by blists - more mailing lists