[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6029c63a-9f26-e677-80c9-4470a96bdfb2@starfivetech.com>
Date: Thu, 23 Feb 2023 14:29:00 +0800
From: Hal Feng <hal.feng@...rfivetech.com>
To: Emil Renner Berthing <emil.renner.berthing@...onical.com>
CC: <linux-clk@...r.kernel.org>, <devicetree@...r.kernel.org>,
<linux-riscv@...ts.infradead.org>, Stephen Boyd <sboyd@...nel.org>,
"Michael Turquette" <mturquette@...libre.com>,
Philipp Zabel <p.zabel@...gutronix.de>,
Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Conor Dooley <conor@...nel.org>,
"Palmer Dabbelt" <palmer@...belt.com>,
Paul Walmsley <paul.walmsley@...ive.com>,
Albert Ou <aou@...s.berkeley.edu>,
Ben Dooks <ben.dooks@...ive.com>,
"Daniel Lezcano" <daniel.lezcano@...aro.org>,
Thomas Gleixner <tglx@...utronix.de>,
Marc Zyngier <maz@...nel.org>, <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v4 13/19] reset: starfive: Add StarFive JH7110 reset
driver
On Tue, 21 Feb 2023 16:33:09 +0100, Emil Renner Berthing wrote:
> On Tue, 21 Feb 2023 at 03:47, Hal Feng <hal.feng@...rfivetech.com> wrote:
>>
>> Add auxiliary driver to support StarFive JH7110 system
>> and always-on resets.
>>
>> Reported-by: kernel test robot <lkp@...el.com>
>> Signed-off-by: Hal Feng <hal.feng@...rfivetech.com>
>> ---
>> drivers/reset/starfive/Kconfig | 8 +++
>> drivers/reset/starfive/Makefile | 1 +
>> .../reset/starfive/reset-starfive-jh7110.c | 64 +++++++++++++++++++
>> .../reset/starfive/reset-starfive-jh71x0.h | 6 ++
>> 4 files changed, 79 insertions(+)
>> create mode 100644 drivers/reset/starfive/reset-starfive-jh7110.c
>>
[...]
>> diff --git a/drivers/reset/starfive/reset-starfive-jh71x0.h b/drivers/reset/starfive/reset-starfive-jh71x0.h
>> index db7d39a87f87..e485472e1adc 100644
>> --- a/drivers/reset/starfive/reset-starfive-jh71x0.h
>> +++ b/drivers/reset/starfive/reset-starfive-jh71x0.h
>> @@ -6,6 +6,12 @@
>> #ifndef __RESET_STARFIVE_JH71X0_H
>> #define __RESET_STARFIVE_JH71X0_H
>>
>> +struct reset_info {
>> + unsigned int nr_resets;
>> + unsigned int assert_offset;
>> + unsigned int status_offset;
>> +};
>
> As far as I can tell this struct isn't used anywhere but in
> reset-starfive-jh7110.c. If so just move it there, and in any case
> please call it something less generic like struct jh7110_reset_info.
OK, will fix it. Thanks.
Best regards,
Hal
>
>> +
>> int reset_starfive_jh71x0_register(struct device *dev, struct device_node *of_node,
>> void __iomem *assert, void __iomem *status,
>> const u32 *asserted, unsigned int nr_resets,
Powered by blists - more mailing lists