[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <04f9336b-2a49-ca3f-fd28-1f04db78d2bd@linaro.org>
Date: Thu, 16 Mar 2023 08:09:51 +0100
From: Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>
To: Konrad Dybcio <konrad.dybcio@...aro.org>,
Rob Clark <robdclark@...il.com>,
Abhinav Kumar <quic_abhinavk@...cinc.com>,
Dmitry Baryshkov <dmitry.baryshkov@...aro.org>,
Sean Paul <sean@...rly.run>, David Airlie <airlied@...il.com>,
Daniel Vetter <daniel@...ll.ch>,
Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Bjorn Andersson <andersson@...nel.org>,
Konrad Dybcio <konrad.dybcio@...ainline.org>,
Akhil P Oommen <quic_akhilpo@...cinc.com>
Cc: linux-arm-msm@...r.kernel.org, dri-devel@...ts.freedesktop.org,
freedreno@...ts.freedesktop.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org, Rob Clark <robdclark@...omium.org>,
Marijn Suijten <marijn.suijten@...ainline.org>
Subject: Re: [PATCH v4 02/14] dt-bindings: display/msm/gmu: Add GMU wrapper
On 14/03/2023 16:28, Konrad Dybcio wrote:
> The "GMU Wrapper" is Qualcomm's name for "let's treat the GPU blocks
> we'd normally assign to the GMU as if they were a part of the GMU, even
> though they are not". It's a (good) software representation of the GMU_CX
> and GMU_GX register spaces within the GPUSS that helps us programatically
> treat these de-facto GMU-less parts in a way that's very similar to their
> GMU-equipped cousins, massively saving up on code duplication.
>
> The "wrapper" register space was specifically designed to mimic the layout
> of a real GMU, though it rather obviously does not have the M3 core et al.
>
> To sum it all up, the GMU wrapper is essentially a register space within
> the GPU, which Linux sees as a dumbed-down regular GMU: there's no clocks,
> interrupts, multiple reg spaces, iommus and OPP. Document it.
>
> Signed-off-by: Konrad Dybcio <konrad.dybcio@...aro.org>
> ---
> .../devicetree/bindings/display/msm/gmu.yaml | 49 ++++++++++++++++------
> 1 file changed, 37 insertions(+), 12 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/display/msm/gmu.yaml b/Documentation/devicetree/bindings/display/msm/gmu.yaml
> index ab14e81cb050..021373e686e1 100644
> --- a/Documentation/devicetree/bindings/display/msm/gmu.yaml
> +++ b/Documentation/devicetree/bindings/display/msm/gmu.yaml
> @@ -19,16 +19,18 @@ description: |
>
> properties:
> compatible:
> - items:
> - - pattern: '^qcom,adreno-gmu-6[0-9][0-9]\.[0-9]$'
> - - const: qcom,adreno-gmu
> + oneOf:
> + - items:
> + - pattern: '^qcom,adreno-gmu-6[0-9][0-9]\.[0-9]$'
> + - const: qcom,adreno-gmu
> + - const: qcom,adreno-gmu-wrapper
>
> reg:
> - minItems: 3
> + minItems: 1
> maxItems: 4
>
> reg-names:
> - minItems: 3
> + minItems: 1
> maxItems: 4
>
> clocks:
> @@ -44,7 +46,6 @@ properties:
> - description: GMU HFI interrupt
> - description: GMU interrupt
>
> -
> interrupt-names:
> items:
> - const: hfi
> @@ -72,14 +73,8 @@ required:
> - compatible
> - reg
> - reg-names
> - - clocks
> - - clock-names
> - - interrupts
> - - interrupt-names
> - power-domains
> - power-domain-names
> - - iommus
> - - operating-points-v2
>
> additionalProperties: false
>
> @@ -216,6 +211,27 @@ allOf:
> - const: cxo
> - const: axi
> - const: memnoc
Blank line (you added such between ifs in previous patch)
Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>
Best regards,
Krzysztof
Powered by blists - more mailing lists