[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <cc819e9b-c613-b3c1-4ea2-8ef828e97508@linux.alibaba.com>
Date: Tue, 21 Mar 2023 10:03:44 +0800
From: Baolin Wang <baolin.wang@...ux.alibaba.com>
To: Cixi Geng <cixi.geng@...ux.dev>, gregkh@...uxfoundation.org,
orsonzhai@...il.com, zhang.lyra@...il.com, arnd@...db.de,
tony@...mide.com, felipe.balbi@...ux.intel.com,
paul@...pouillou.net, linus.walleij@...aro.org,
cixi.geng1@...soc.com, gengcixi@...il.com
Cc: linux-kernel@...r.kernel.org, linux-usb@...r.kernel.org
Subject: Re: [RFC PATCH v1] usb/phy add sprd ums512 usbphy
On 3/18/2023 11:37 PM, Cixi Geng wrote:
> On Mon, 2023-03-13 at 17:11 +0800, Baolin Wang wrote:
>>
>>
...
>>> +
>>> +MODULE_DESCRIPTION("UNISOC USB PHY driver");
>>> +MODULE_LICENSE("GPL");
>>> diff --git a/drivers/usb/phy/phy-sprd-ums512.h
>>> b/drivers/usb/phy/phy-sprd-ums512.h
>>> new file mode 100644
>>> index 000000000000..903da0573eae
>>> --- /dev/null
>>> +++ b/drivers/usb/phy/phy-sprd-ums512.h
>>> @@ -0,0 +1,39 @@
>>> +/* SPDX-License-Identifier: GPL-2.0+ OR MIT */
>>> +/*
>>> + * Spreadtrum UMS512 SOC USB registers file
>>> + *
>>> + * Copyright C 2022, Spreadtrum Communications Inc.
>>> + */
>>> +
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_DATABUS16_8
>>> 0x10000000
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_DMPULLDOWN 0x8
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_DPPULLDOWN 0x10
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_ISO_SW_EN 0x1
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_PS_PD_L 0x8
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_PS_PD_S 0x10
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_RESERVED 0xff
>>> ff
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_TFREGRES 0x1f
>>> 80000
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_TUNEHSAMP 0x60
>>> 00000
>>> +#define
>>> MASK_ANLG_PHY_G2_ANALOG_USB20_USB20_VBUSVLDEXT 0x10
>>> 000
>>> +#define
>>> MASK_ANLG_PHY_G2_DBG_SEL_ANALOG_USB20_USB20_DMPULLDOWN 0x2
>>> +#define
>>> MASK_ANLG_PHY_G2_DBG_SEL_ANALOG_USB20_USB20_DPPULLDOWN 0x4
>>> +#define
>>> MASK_AON_APB_ANA_EB 0x10
>>> 00
>>> +#define
>>> MASK_AON_APB_CGM_DPHY_REF_EN 0x40
>>> 0
>>> +#define
>>> MASK_AON_APB_CGM_OTG_REF_EN 0x10
>>> 00
>>> +#define
>>> MASK_AON_APB_OTG_PHY_SOFT_RST 0x20
>>> 0
>>> +#define
>>> MASK_AON_APB_OTG_UTMI_EB 0x10
>>> 0
>>> +#define
>>> MASK_AON_APB_OTG_UTMI_SOFT_RST 0x10
>>> 0
>>> +#define
>>> MASK_AON_APB_OTG_VBUS_VALID_PHYREG 0x10
>>> 00000
>>> +#define
>>> MASK_AON_APB_USB2_PHY_IDDIG 0x8
>>> +#define
>>> MASK_AON_APB_UTMI_WIDTH_SEL 0x40
>>> 000000
>>> +#define
>>> REG_ANLG_PHY_G2_ANALOG_USB20_USB20_BATTER_PLL 0x00
>>> 5c
>>> +#define
>>> REG_ANLG_PHY_G2_ANALOG_USB20_USB20_ISO_SW 0x00
>>> 70
>>> +#define
>>> REG_ANLG_PHY_G2_ANALOG_USB20_USB20_TRIMMING 0x00
>>> 64
>>> +#define
>>> REG_ANLG_PHY_G2_ANALOG_USB20_USB20_UTMI_CTL1 0x00
>>> 58
>>> +#define
>>> REG_ANLG_PHY_G2_ANALOG_USB20_USB20_UTMI_CTL2 0x00
>>> 60
>>> +#define
>>> REG_ANLG_PHY_G2_ANALOG_USB20_REG_SEL_CFG_0 0x00
>>> 74
>>> +#define
>>> REG_AON_APB_APB_EB1 0x00
>>> 04
>>> +#define
>>> REG_AON_APB_APB_RST1 0x00
>>> 10
>>> +#define
>>> REG_AON_APB_CGM_REG1 0x01
>>> 38
>>> +#define
>>> REG_AON_APB_OTG_PHY_CTRL 0x02
>>> 08
>>> +#define
>>> REG_AON_APB_OTG_PHY_TEST 0x02
>>> 04
>>
>> Move them to the driver file and please rename the ugly macro names,
>> too
>> long :(
>>
>> And why not move the usb phy driver to be a generic phy driver? I
>> mean
>> move it to the drivers/phy.
> Do you mean all the usb-phy need move to driver/phy? or just this
> driver?
If I remember correctly, new phy drivers should go to the generic phy
framework unless there are some reasons to prevent.
Greg, how do you think?
Powered by blists - more mailing lists