[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZHACWWNIUR6Ohh/8@moria.home.lan>
Date: Thu, 25 May 2023 20:50:33 -0400
From: Kent Overstreet <kent.overstreet@...ux.dev>
To: Dave Chinner <david@...morbit.com>
Cc: linux-kernel@...r.kernel.org, axboe@...nel.dk,
linux-block@...r.kernel.org, linux-fsdevel@...r.kernel.org,
Matthew Wilcox <willy@...radead.org>
Subject: Re: [PATCH 5/7] block: Rework bio_for_each_folio_all()
On Fri, May 26, 2023 at 10:36:03AM +1000, Dave Chinner wrote:
> On Thu, May 25, 2023 at 05:48:20PM -0400, Kent Overstreet wrote:
> > This reimplements bio_for_each_folio_all() on top of the newly-reworked
> > bvec_iter_all, and since it's now trivial we also provide
> > bio_for_each_folio.
> >
> > Signed-off-by: Kent Overstreet <kent.overstreet@...ux.dev>
> > Cc: Matthew Wilcox <willy@...radead.org>
> > Cc: linux-block@...r.kernel.org
> > ---
> > fs/crypto/bio.c | 9 +++--
> > fs/iomap/buffered-io.c | 14 ++++---
> > fs/verity/verify.c | 9 +++--
> > include/linux/bio.h | 91 +++++++++++++++++++++---------------------
> > include/linux/bvec.h | 15 +++++--
> > 5 files changed, 75 insertions(+), 63 deletions(-)
> ....
> > diff --git a/include/linux/bio.h b/include/linux/bio.h
> > index f86c7190c3..7ced281734 100644
> > --- a/include/linux/bio.h
> > +++ b/include/linux/bio.h
> > @@ -169,6 +169,42 @@ static inline void bio_advance(struct bio *bio, unsigned int nbytes)
> > #define bio_for_each_segment(bvl, bio, iter) \
> > __bio_for_each_segment(bvl, bio, iter, (bio)->bi_iter)
> >
> > +struct folio_vec {
> > + struct folio *fv_folio;
> > + size_t fv_offset;
> > + size_t fv_len;
> > +};
>
> Can we drop the "fv_" variable prefix here? It's just unnecessary
> verbosity when we know we have a folio_vec structure. i.e fv->folio
> is easier to read and type than fv->fv_folio...
That's actually one of the things I like about bio/biovec, it's been
handy in the past for grepping and block layer refactorings...
(I would _kill_ for a tool that let me do that kind of type-aware grep.
ctags can in theory produce that kind of an index but I never figured
out how to get vim to use it properly. I believe the lsp-server stuff
that uses the compiler as a backend can do it; I've started using that
stuff for Rust coding and it works amazingly, don't think I've tried it
for struct members - I wonder if that stuff works at all on a codebase
the size of the kernel or just dies...)
> Hmmm, this is probably not a good name considering "struct pagevec" is
> something completely different - the equivalent is "struct
> folio_batch" but I can see this being confusing for people who
> largely expect some symmetry between page<->folio naming
> conventions...
Yeah, good point. folio_seg, perhaps?
(I think Matthew may have already made that suggestion...)
> Also, why is this in bio.h and not in a mm/folio related header
> file?
Is it worth moving it there considering it's only used in bio.h/bvec.h?
Perhaps we could keep it where it's used for now and move it if it gains
more users?
Powered by blists - more mailing lists