lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZHZLjRPSYCOYjkBo@aschofie-mobl2>
Date:   Tue, 30 May 2023 12:16:29 -0700
From:   Alison Schofield <alison.schofield@...el.com>
To:     Miaohe Lin <linmiaohe@...wei.com>
Cc:     tony.luck@...el.com, bp@...en8.de, tglx@...utronix.de,
        mingo@...hat.com, dave.hansen@...ux.intel.com, hpa@...or.com,
        x86@...nel.org, linux-edac@...r.kernel.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] x86/mce: remove unused mce_vaddr

On Sun, May 28, 2023 at 07:35:45PM +0800, Miaohe Lin wrote:
> Since commit a6e3cf70b772 ("x86/mce: Change to not send SIGBUS error during
> copy from user"), mce_vaddr is not used anymore. Remove it and clean up the
> relevant code.

Hi Miaohe,

Not so sure that the 'clean up' part is useful. See below.


> 
> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
> ---
>  arch/x86/kernel/cpu/mce/severity.c | 7 +------
>  include/linux/sched.h              | 1 -
>  2 files changed, 1 insertion(+), 7 deletions(-)
> 
> diff --git a/arch/x86/kernel/cpu/mce/severity.c b/arch/x86/kernel/cpu/mce/severity.c
> index c4477162c07d..0acc0039de81 100644
> --- a/arch/x86/kernel/cpu/mce/severity.c
> +++ b/arch/x86/kernel/cpu/mce/severity.c
> @@ -252,12 +252,7 @@ static bool is_copy_from_user(struct pt_regs *regs)
>  		return false;
>  	}
>  
> -	if (fault_in_kernel_space(addr))
> -		return false;
> -
> -	current->mce_vaddr = (void __user *)addr;
> -
> -	return true;
> +	return !fault_in_kernel_space(addr);
>  }


Refactoring the return is unnecessary and seems less readable.
How about removing the assignment, and leaving the rest, as is:

diff --git a/arch/x86/kernel/cpu/mce/severity.c b/arch/x86/kernel/cpu/mce/severity.c
index c4477162c07d..1c03221ddcb1 100644
--- a/arch/x86/kernel/cpu/mce/severity.c
+++ b/arch/x86/kernel/cpu/mce/severity.c
@@ -255,8 +255,6 @@ static bool is_copy_from_user(struct pt_regs *regs)
        if (fault_in_kernel_space(addr))
                return false;
 
-       current->mce_vaddr = (void __user *)addr;
-
        return true;
 }


Alison




>  
>  /*
> diff --git a/include/linux/sched.h b/include/linux/sched.h
> index eed5d65b8d1f..3054a7087230 100644
> --- a/include/linux/sched.h
> +++ b/include/linux/sched.h
> @@ -1493,7 +1493,6 @@ struct task_struct {
>  #endif
>  
>  #ifdef CONFIG_X86_MCE
> -	void __user			*mce_vaddr;
>  	__u64				mce_kflags;
>  	u64				mce_addr;
>  	__u64				mce_ripv : 1,
> -- 
> 2.27.0
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ