[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <6f36b268-0717-1bb4-6f78-53758a88c04a@huawei.com>
Date: Sat, 3 Jun 2023 11:17:08 +0800
From: Miaohe Lin <linmiaohe@...wei.com>
To: Alison Schofield <alison.schofield@...el.com>
CC: <tony.luck@...el.com>, <bp@...en8.de>, <tglx@...utronix.de>,
<mingo@...hat.com>, <dave.hansen@...ux.intel.com>, <hpa@...or.com>,
<x86@...nel.org>, <linux-edac@...r.kernel.org>,
<linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] x86/mce: remove unused mce_vaddr
On 2023/5/31 3:16, Alison Schofield wrote:
> On Sun, May 28, 2023 at 07:35:45PM +0800, Miaohe Lin wrote:
>> Since commit a6e3cf70b772 ("x86/mce: Change to not send SIGBUS error during
>> copy from user"), mce_vaddr is not used anymore. Remove it and clean up the
>> relevant code.
>
> Hi Miaohe,
>
> Not so sure that the 'clean up' part is useful. See below.
>
>
>>
>> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
>> ---
>> arch/x86/kernel/cpu/mce/severity.c | 7 +------
>> include/linux/sched.h | 1 -
>> 2 files changed, 1 insertion(+), 7 deletions(-)
>>
>> diff --git a/arch/x86/kernel/cpu/mce/severity.c b/arch/x86/kernel/cpu/mce/severity.c
>> index c4477162c07d..0acc0039de81 100644
>> --- a/arch/x86/kernel/cpu/mce/severity.c
>> +++ b/arch/x86/kernel/cpu/mce/severity.c
>> @@ -252,12 +252,7 @@ static bool is_copy_from_user(struct pt_regs *regs)
>> return false;
>> }
>>
>> - if (fault_in_kernel_space(addr))
>> - return false;
>> -
>> - current->mce_vaddr = (void __user *)addr;
>> -
>> - return true;
>> + return !fault_in_kernel_space(addr);
>> }
>
>
> Refactoring the return is unnecessary and seems less readable.
> How about removing the assignment, and leaving the rest, as is:
>
> diff --git a/arch/x86/kernel/cpu/mce/severity.c b/arch/x86/kernel/cpu/mce/severity.c
> index c4477162c07d..1c03221ddcb1 100644
> --- a/arch/x86/kernel/cpu/mce/severity.c
> +++ b/arch/x86/kernel/cpu/mce/severity.c
> @@ -255,8 +255,6 @@ static bool is_copy_from_user(struct pt_regs *regs)
> if (fault_in_kernel_space(addr))
> return false;
>
> - current->mce_vaddr = (void __user *)addr;
> -
> return true;
> }
>
Sounds good to me. Will do it in v2. Thanks for your advice.
Powered by blists - more mailing lists