[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230608091130.bthttzsmdeeiagof@quack3>
Date: Thu, 8 Jun 2023 11:11:30 +0200
From: Jan Kara <jack@...e.cz>
To: Christoph Hellwig <hch@...radead.org>
Cc: Jan Kara <jack@...e.cz>, "Darrick J. Wong" <djwong@...nel.org>,
Luis Chamberlain <mcgrof@...nel.org>, sandeen@...deen.net,
song@...nel.org, rafael@...nel.org, gregkh@...uxfoundation.org,
viro@...iv.linux.org.uk, jikos@...nel.org, bvanassche@....org,
ebiederm@...ssion.com, mchehab@...nel.org, keescook@...omium.org,
p.raghav@...sung.com, da.gomez@...sung.com,
linux-fsdevel@...r.kernel.org, kernel@...force.de,
kexec@...ts.infradead.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/6] fs: distinguish between user initiated freeze and
kernel initiated freeze
On Wed 07-06-23 22:29:04, Christoph Hellwig wrote:
> On Thu, May 25, 2023 at 04:14:30PM +0200, Jan Kara wrote:
> > Yes, this is exactly how I'd imagine it. Thanks for writing the patch!
> >
> > I'd just note that this would need rebasing on top of Luis' patches 1 and
> > 2. Also:
>
> I'd not do that for now. 1 needs a lot more work, and 2 seems rather
> questionable.
OK, I agree the wrappers could be confusing (they didn't confuse me but
when you spelled it out, I agree).
> > Now the only remaining issue with the code is that the two different
> > holders can be attempting to freeze the filesystem at once and in that case
> > one of them has to wait for the other one instead of returning -EBUSY as
> > would happen currently. This can happen because we temporarily drop
> > s_umount in freeze_super() due to lock ordering issues. I think we could
> > do something like:
> >
> > if (!sb_unfrozen(sb)) {
> > up_write(&sb->s_umount);
> > wait_var_event(&sb->s_writers.frozen,
> > sb_unfrozen(sb) || sb_frozen(sb));
> > down_write(&sb->s_umount);
> > goto retry;
> > }
> >
> > and then sprinkle wake_up_var(&sb->s_writers.frozen) at appropriate places
> > in freeze_super().
>
> Let's do that separately as a follow on..
Well, we need to somehow settle on how to deal with a race when both kernel
& userspace race to freeze the filesystem and make the result consistent
with the situation when the fs is already frozen by someone.
> > BTW, when reading this code, I've spotted attached cleanup opportunity but
> > I'll queue that separately so that is JFYI.
> >
> > > +#define FREEZE_HOLDER_USERSPACE (1U << 1) /* userspace froze fs */
> > > +#define FREEZE_HOLDER_KERNEL (1U << 2) /* kernel froze fs */
> >
> > Why not start from 1U << 0? And bonus points for using BIT() macro :).
>
> BIT() is a nasty thing and actually makes code harder to read. And it
> doesn't interact very well with the __bitwise annotation that might
> actually be useful here.
OK. I'm not too hung up on BIT() macro.
Honza
--
Jan Kara <jack@...e.com>
SUSE Labs, CR
Powered by blists - more mailing lists