[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZN3ncVjDn9ZXHOS5@smile.fi.intel.com>
Date: Thu, 17 Aug 2023 12:25:05 +0300
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Bartosz Golaszewski <brgl@...ev.pl>
Cc: Linus Walleij <linus.walleij@...aro.org>,
Kent Gibson <warthog618@...il.com>, linux-gpio@...r.kernel.org,
linux-kernel@...r.kernel.org,
Bartosz Golaszewski <bartosz.golaszewski@...aro.org>
Subject: Re: [PATCH v3] gpio: sim: simplify code with cleanup helpers
On Tue, Aug 15, 2023 at 09:09:55PM +0200, Bartosz Golaszewski wrote:
> On Tue, Aug 15, 2023 at 12:31 PM Andy Shevchenko
> <andriy.shevchenko@...ux.intel.com> wrote:
> > On Sat, Aug 12, 2023 at 08:36:35PM +0200, Bartosz Golaszewski wrote:
...
> > > - mutex_lock(&chip->lock);
> > > - __assign_bit(offset, chip->value_map, value);
> > > - mutex_unlock(&chip->lock);
> > > + scoped_guard(mutex, &chip->lock)
> > > + __assign_bit(offset, chip->value_map, value);
> >
> > But this can also be guarded.
> >
> > guard(mutex)(&chip->lock);
> >
> > __assign_bit(offset, chip->value_map, value);
>
> Come on, this is total bikeshedding! I could produce ten arguments in
> favor of the scoped variant.
>
> Linus acked even the previous version and Peter says it looks right. I
> will queue it unless some *real* issues come up.
I still think this will be, besides being shorter and nicer to read,
more consistent with other simple use of "guard(); return ..." cases.
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists