[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <663c85bb-90c3-4ae1-ab0b-5ab1a8abd2a7@kadam.mountain>
Date: Fri, 13 Oct 2023 11:53:36 +0300
From: Dan Carpenter <dan.carpenter@...aro.org>
To: Soumya Negi <soumya.negi97@...il.com>
Cc: Jonathan Kim <jonathankim@...semi.com>,
Dean ahn <deanahn@...semi.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
outreachy@...ts.linux.dev, linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] tty: gdm724x: Fix coding style checkpatch warnings
On Thu, Oct 12, 2023 at 10:14:58PM -0700, Soumya Negi wrote:
> @@ -271,8 +272,8 @@ int register_lte_tty_driver(void)
> int ret;
>
> for (i = 0; i < TTY_MAX_COUNT; i++) {
> - tty_driver = tty_alloc_driver(GDM_TTY_MINOR,
> - TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV);
> + tty_driver = tty_alloc_driver(GDM_TTY_MINOR, TTY_DRIVER_REAL_RAW |
> + TTY_DRIVER_DYNAMIC_DEV);
Don't do this. The code was better before. The parameter
"TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV" is one thing and
splitting it up like that makes the code less readable. And I bet they
had to indent it like that to get under the 80 character limit.
This is an example of checkpatch giving bad advice.
regards,
dan carpenter
Powered by blists - more mailing lists