[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e8a55d0518da5c1f9aba739359150cad58c03b2b.camel@redhat.com>
Date: Tue, 31 Oct 2023 10:18:28 +0100
From: Paolo Abeni <pabeni@...hat.com>
To: Lucas Karpinski <lkarpins@...hat.com>, davem@...emloft.net,
edumazet@...gle.com, kuba@...nel.org, shuah@...nel.org
Cc: netdev@...r.kernel.org, linux-kselftest@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2] selftests/net: synchronize udpgso_bench rx and tx
On Mon, 2023-10-30 at 13:40 -0400, Lucas Karpinski wrote:
> The sockets used by udpgso_bench_tx aren't always ready when
> udpgso_bench_tx transmits packets. This issue is more prevalent in -rt
> kernels, but can occur in both. Replace the hacky sleep calls with a
> function that checks whether the ports in the namespace are ready for
> use.
>
> Suggested-by: Paolo Abeni <pabeni@...hat.com>
> Signed-off-by: Lucas Karpinski <lkarpins@...hat.com>
> ---
> https://lore.kernel.org/all/t7v6mmuobrbucyfpwqbcujtvpa3wxnsrc36cz5rr6kzzrzkwtj@toz6mr4ggnyp/
>
> Changelog v2:
> - applied synchronization method suggested by Pablo
> - changed commit message to code
>
> tools/testing/selftests/net/udpgro.sh | 27 ++++++++++++++-----
> tools/testing/selftests/net/udpgro_bench.sh | 19 +++++++++++--
> tools/testing/selftests/net/udpgro_frglist.sh | 19 +++++++++++--
> 3 files changed, 54 insertions(+), 11 deletions(-)
>
> diff --git a/tools/testing/selftests/net/udpgro.sh b/tools/testing/selftests/net/udpgro.sh
> index 0c743752669a..04792a315729 100755
> --- a/tools/testing/selftests/net/udpgro.sh
> +++ b/tools/testing/selftests/net/udpgro.sh
> @@ -24,6 +24,22 @@ cleanup() {
> }
> trap cleanup EXIT
>
> +wait_local_port_listen()
> +{
> + local port="${1}"
> +
> + local port_hex
> + port_hex="$(printf "%04X" "${port}")"
> +
> + local i
Minor nit: I think the code would be more readable, if you will group
the variable together:
local port="${1}"
local port_hex
local i
port_hex="$(printf "%04X" "${port}")"
# ...
> + for i in $(seq 10); do
> + ip netns exec "${PEER_NS}" cat /proc/net/udp* | \
> + awk "BEGIN {rc=1} {if (\$2 ~ /:${port_hex}\$/) {rc=0; exit}} END {exit rc}" &&
> + break
> + sleep 0.1
> + done
> +}
Since you wrote the same function verbatim in 3 different files, I
think it would be better place it in separate, new, net_helper.sh file
and include such file from the various callers. Possibly additionally
rename the function as wait_local_udp_port_listen.
Thanks!
Paolo
Powered by blists - more mailing lists