[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5a7a675238c2e29d02ae23f0ec0e1569415eb89e.camel@huaweicloud.com>
Date: Thu, 16 Nov 2023 10:46:24 +0100
From: Roberto Sassu <roberto.sassu@...weicloud.com>
To: Paul Moore <paul@...l-moore.com>, viro@...iv.linux.org.uk,
brauner@...nel.org, chuck.lever@...cle.com, jlayton@...nel.org,
neilb@...e.de, kolga@...app.com, Dai.Ngo@...cle.com,
tom@...pey.com, jmorris@...ei.org, serge@...lyn.com,
zohar@...ux.ibm.com, dmitry.kasatkin@...il.com,
dhowells@...hat.com, jarkko@...nel.org,
stephen.smalley.work@...il.com, eparis@...isplace.org,
casey@...aufler-ca.com, mic@...ikod.net
Cc: linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-nfs@...r.kernel.org, linux-security-module@...r.kernel.org,
linux-integrity@...r.kernel.org, keyrings@...r.kernel.org,
selinux@...r.kernel.org, Roberto Sassu <roberto.sassu@...wei.com>
Subject: Re: [PATCH v5 13/23] security: Introduce file_pre_free_security hook
On Wed, 2023-11-15 at 23:33 -0500, Paul Moore wrote:
> On Nov 7, 2023 Roberto Sassu <roberto.sassu@...weicloud.com> wrote:
> >
> > In preparation for moving IMA and EVM to the LSM infrastructure, introduce
> > the file_pre_free_security hook.
> >
> > IMA calculates at file close the new digest of the file content and writes
> > it to security.ima, so that appraisal at next file access succeeds.
> >
> > LSMs could also take some action before the last reference of a file is
> > released.
> >
> > The new hook cannot return an error and cannot cause the operation to be
> > reverted.
> >
> > Signed-off-by: Roberto Sassu <roberto.sassu@...wei.com>
> > Acked-by: Casey Schaufler <casey@...aufler-ca.com>
> > Reviewed-by: Mimi Zohar <zohar@...ux.ibm.com>
> > ---
> > fs/file_table.c | 1 +
> > include/linux/lsm_hook_defs.h | 1 +
> > include/linux/security.h | 4 ++++
> > security/security.c | 11 +++++++++++
> > 4 files changed, 17 insertions(+)
> >
> > diff --git a/fs/file_table.c b/fs/file_table.c
> > index de4a2915bfd4..64ed74555e64 100644
> > --- a/fs/file_table.c
> > +++ b/fs/file_table.c
> > @@ -385,6 +385,7 @@ static void __fput(struct file *file)
> > eventpoll_release(file);
> > locks_remove_file(file);
> >
> > + security_file_pre_free(file);
>
> I worry that security_file_pre_free() is a misleading name as "free"
> tends to imply memory management tasks, which isn't the main focus of
> this hook. What do you think of security_file_release() or
> security_file_put() instead?
security_file_release() would be fine for me.
Thanks
Roberto
> > ima_file_free(file);
> > if (unlikely(file->f_flags & FASYNC)) {
> > if (file->f_op->fasync)
>
> --
> paul-moore.com
Powered by blists - more mailing lists