[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZVyzgmb/+oUJ1xcR@yury-ThinkPad>
Date: Tue, 21 Nov 2023 05:41:22 -0800
From: Yury Norov <yury.norov@...il.com>
To: Alexandra Winter <wintera@...ux.ibm.com>
Cc: linux-kernel@...r.kernel.org, Karsten Graul <kgraul@...ux.ibm.com>,
Wenjia Zhang <wenjia@...ux.ibm.com>,
Jan Karcher <jaka@...ux.ibm.com>,
"D. Wythe" <alibuda@...ux.alibaba.com>,
Tony Lu <tonylu@...ux.alibaba.com>,
Wen Gu <guwen@...ux.alibaba.com>,
"David S. Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>, linux-s390@...r.kernel.org,
netdev@...r.kernel.org, Jan Kara <jack@...e.cz>,
Mirsad Todorovac <mirsad.todorovac@....unizg.hr>,
Matthew Wilcox <willy@...radead.org>,
Rasmus Villemoes <linux@...musvillemoes.dk>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Maxim Kuvyrkov <maxim.kuvyrkov@...aro.org>,
Alexey Klimov <klimov.linux@...il.com>
Subject: Re: [PATCH 29/34] net: smc: fix opencoded find_and_set_bit() in
smc_wr_tx_get_free_slot_index()
On Mon, Nov 20, 2023 at 09:43:54AM +0100, Alexandra Winter wrote:
>
>
> On 18.11.23 16:51, Yury Norov wrote:
> > The function opencodes find_and_set_bit() with a for_each() loop. Fix
> > it, and make the whole function a simple almost one-liner.
> >
> > Signed-off-by: Yury Norov <yury.norov@...il.com>
> > ---
> > net/smc/smc_wr.c | 10 +++-------
> > 1 file changed, 3 insertions(+), 7 deletions(-)
> >
> > diff --git a/net/smc/smc_wr.c b/net/smc/smc_wr.c
> > index 0021065a600a..b6f0cfc52788 100644
> > --- a/net/smc/smc_wr.c
> > +++ b/net/smc/smc_wr.c
> > @@ -170,15 +170,11 @@ void smc_wr_tx_cq_handler(struct ib_cq *ib_cq, void *cq_context)
> >
> > static inline int smc_wr_tx_get_free_slot_index(struct smc_link *link, u32 *idx)
> > {
> > - *idx = link->wr_tx_cnt;
> > if (!smc_link_sendable(link))
> > return -ENOLINK;
> > - for_each_clear_bit(*idx, link->wr_tx_mask, link->wr_tx_cnt) {
> > - if (!test_and_set_bit(*idx, link->wr_tx_mask))
> > - return 0;
> > - }
> > - *idx = link->wr_tx_cnt;
> > - return -EBUSY;
> > +
> > + *idx = find_and_set_bit(link->wr_tx_mask, link->wr_tx_cnt);
> > + return *idx < link->wr_tx_cnt ? 0 : -EBUSY;
> > }
> >
> > /**
>
>
> My understanding is that you can omit the lines with
> > - *idx = link->wr_tx_cnt;
> because they only apply to the error paths and you checked that the calling function
> does not use the idx variable in the error cases. Do I understand this correct?
>
> If so the removal of these 2 lines is not related to your change of using find_and_set_bit(),
> do I understand that correctly?
>
> If so, it may be worth mentioning that in the commit message.
I'll add:
If find_and_set_bit() doesn't acquire a bit, it returns
->wr_tx_cnt, and so explicit initialization of *idx with
the same value is unneeded.
Makes sense?
Powered by blists - more mailing lists