[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20231206170807.GBZXCqd0z8uu2rlhpn@fat_crate.local>
Date: Wed, 6 Dec 2023 18:08:07 +0100
From: Borislav Petkov <bp@...en8.de>
To: "Kalra, Ashish" <ashish.kalra@....com>
Cc: Michael Roth <michael.roth@....com>, kvm@...r.kernel.org,
linux-coco@...ts.linux.dev, linux-mm@...ck.org,
linux-crypto@...r.kernel.org, x86@...nel.org,
linux-kernel@...r.kernel.org, tglx@...utronix.de, mingo@...hat.com,
jroedel@...e.de, thomas.lendacky@....com, hpa@...or.com,
ardb@...nel.org, pbonzini@...hat.com, seanjc@...gle.com,
vkuznets@...hat.com, jmattson@...gle.com, luto@...nel.org,
dave.hansen@...ux.intel.com, slp@...hat.com, pgonda@...gle.com,
peterz@...radead.org, srinivas.pandruvada@...ux.intel.com,
rientjes@...gle.com, dovmurik@...ux.ibm.com, tobin@....com,
vbabka@...e.cz, kirill@...temov.name, ak@...ux.intel.com,
tony.luck@...el.com, marcorr@...gle.com,
sathyanarayanan.kuppuswamy@...ux.intel.com, alpergun@...gle.com,
jarkko@...nel.org, nikunj.dadhania@....com, pankaj.gupta@....com,
liam.merwick@...cle.com, zhi.a.wang@...el.com,
Brijesh Singh <brijesh.singh@....com>,
Jarkko Sakkinen <jarkko@...fian.com>
Subject: Re: [PATCH v10 14/50] crypto: ccp: Add support to initialize the
AMD-SP for SEV-SNP
On Wed, Nov 29, 2023 at 08:13:52PM -0600, Kalra, Ashish wrote:
> It surely seems hard to follow up, so i am anyway going to clean it up by:
>
> Adding the "probe" parameter to sev_platform_init() where the parameter
> being true indicates that we only want to do SNP initialization on probe,
> the same parameter will get passed on to
> __sev_platform_init_locked().
That's exactly what you should *not* do - the probe parameter controls
whether
if (psp_init_on_probe)
__sev_platform_init_locked(error);
and so on should get executed or not.
If it is unclear, lemme know and I'll do a diff to show you what I mean.
> > > + /* Prepare for first SNP guest launch after INIT */
> > > + wbinvd_on_all_cpus();
> >
> > Why is that WBINVD needed?
>
> As the comment above mentions, WBINVD + DF_FLUSH is needed before the first
> guest launch.
Lemme see if I get this straight. The correct order is:
WBINVD
SNP_INIT_*
WBINVD
DF_FLUSH
If so, do a comment which goes like this:
/*
* The order of commands to execute before the first guest
* launch is the following:
*
* bla...
*/
> In the latest code base, _sev_snp_shutdown_locked() is called from
> __sev_firmware_shutdown().
Then carve that function out only when needed - do not do changes
preemptively. This is not helping during review.
Thx.
--
Regards/Gruss,
Boris.
https://people.kernel.org/tglx/notes-about-netiquette
Powered by blists - more mailing lists