[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZXnj1WhpSgdMXSfS@yury-ThinkPad>
Date: Wed, 13 Dec 2023 09:03:17 -0800
From: Yury Norov <yury.norov@...il.com>
To: Ming Lei <ming.lei@...hat.com>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Thomas Gleixner <tglx@...utronix.de>,
linux-kernel@...r.kernel.org,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Rasmus Villemoes <linux@...musvillemoes.dk>
Subject: Re: [PATCH v3 3/7] lib/group_cpus: relax atomicity requirement in
grp_spread_init_one()
On Wed, Dec 13, 2023 at 08:14:45AM +0800, Ming Lei wrote:
> On Tue, Dec 12, 2023 at 08:52:14AM -0800, Yury Norov wrote:
> > On Tue, Dec 12, 2023 at 05:50:04PM +0800, Ming Lei wrote:
> > > On Mon, Dec 11, 2023 at 08:21:03PM -0800, Yury Norov wrote:
> > > > Because nmsk and irqmsk are stable, extra atomicity is not required.
> > > >
> > > > Signed-off-by: Yury Norov <yury.norov@...il.com>
> > > > ---
> > > > lib/group_cpus.c | 8 ++++----
> > > > 1 file changed, 4 insertions(+), 4 deletions(-)
> > > >
> > > > diff --git a/lib/group_cpus.c b/lib/group_cpus.c
> > > > index 10dead3ab0e0..7ac94664230f 100644
> > > > --- a/lib/group_cpus.c
> > > > +++ b/lib/group_cpus.c
> > > > @@ -24,8 +24,8 @@ static void grp_spread_init_one(struct cpumask *irqmsk, struct cpumask *nmsk,
> > > > if (cpu >= nr_cpu_ids)
> > > > return;
> > > >
> > > > - cpumask_clear_cpu(cpu, nmsk);
> > > > - cpumask_set_cpu(cpu, irqmsk);
> > > > + __cpumask_clear_cpu(cpu, nmsk);
> > > > + __cpumask_set_cpu(cpu, irqmsk);
> > > > cpus_per_grp--;
> > > >
> > > > /* If the cpu has siblings, use them first */
> > > > @@ -33,8 +33,8 @@ static void grp_spread_init_one(struct cpumask *irqmsk, struct cpumask *nmsk,
> > > > sibl = cpu + 1;
> > > >
> > > > for_each_cpu_and_from(sibl, siblmsk, nmsk) {
> > > > - cpumask_clear_cpu(sibl, nmsk);
> > > > - cpumask_set_cpu(sibl, irqmsk);
> > > > + __cpumask_clear_cpu(sibl, nmsk);
> > > > + __cpumask_set_cpu(sibl, irqmsk);
> > >
> > > I think this kind of change should be avoided, here the code is
> > > absolutely in slow path, and we care code cleanness and readability
> > > much more than the saved cycle from non atomicity.
> >
> > Atomic ops have special meaning and special function. This 'atomic' way
> > of moving a bit from one bitmap to another looks completely non-trivial
> > and puzzling to me.
> >
> > A sequence of atomic ops is not atomic itself. Normally it's a sing of
> > a bug. But in this case, both masks are stable, and we don't need
> > atomicity at all.
>
> Here we don't care the atomicity.
>
> >
> > It's not about performance, it's about readability.
>
> __cpumask_clear_cpu() and __cpumask_set_cpu() are more like private
> helper, and more hard to follow.
No that's not true. Non-atomic version of the function is not a
private helper of course.
> [@linux]$ git grep -n -w -E "cpumask_clear_cpu|cpumask_set_cpu" ./ | wc
> 674 2055 53954
> [@linux]$ git grep -n -w -E "__cpumask_clear_cpu|__cpumask_set_cpu" ./ | wc
> 21 74 1580
>
> I don't object to comment the current usage, but NAK for this change.
No problem, I'll add you NAK.
Powered by blists - more mailing lists