lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZYLncuCz1P_Y2hYW@localhost.localdomain>
Date: Wed, 20 Dec 2023 14:09:06 +0100
From: Frederic Weisbecker <frederic@...nel.org>
To: Anna-Maria Behnsen <anna-maria@...utronix.de>
Cc: linux-kernel@...r.kernel.org, Peter Zijlstra <peterz@...radead.org>,
	John Stultz <jstultz@...gle.com>,
	Thomas Gleixner <tglx@...utronix.de>,
	Eric Dumazet <edumazet@...gle.com>,
	"Rafael J . Wysocki" <rafael.j.wysocki@...el.com>,
	Arjan van de Ven <arjan@...radead.org>,
	"Paul E . McKenney" <paulmck@...nel.org>,
	Rik van Riel <riel@...riel.com>,
	Steven Rostedt <rostedt@...dmis.org>,
	Sebastian Siewior <bigeasy@...utronix.de>,
	Giovanni Gherdovich <ggherdovich@...e.cz>,
	Lukasz Luba <lukasz.luba@....com>,
	"Gautham R . Shenoy" <gautham.shenoy@....com>,
	Srinivas Pandruvada <srinivas.pandruvada@...el.com>,
	K Prateek Nayak <kprateek.nayak@....com>
Subject: Re: [PATCH v9 01/32] tick-sched: Fix function names in comments

Le Fri, Dec 01, 2023 at 10:26:23AM +0100, Anna-Maria Behnsen a écrit :
> When referencing functions in comments, it might be helpful to use full
> function names (including the prefix) to be able to find it when grepping.
> 
> Signed-off-by: Anna-Maria Behnsen <anna-maria@...utronix.de>

Reviewed-by: Frederic Weisbecker <frederic@...nel.org>

Just a small detail that be addressed as a further patch (or edited
while applying).

> ---
> v9: New cleanup patch
> ---
>  kernel/time/tick-sched.c | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/kernel/time/tick-sched.c b/kernel/time/tick-sched.c
> index be77b021e5d6..5c28cc80fd25 100644
> --- a/kernel/time/tick-sched.c
> +++ b/kernel/time/tick-sched.c
> @@ -920,11 +920,11 @@ static void tick_nohz_stop_tick(struct tick_sched *ts, int cpu)
>  	}
>  
>  	/*
> -	 * nohz_stop_sched_tick() can be called several times before
> -	 * nohz_restart_sched_tick() is called. This happens when
> -	 * interrupts arrive which do not cause a reschedule. In the
> -	 * first call we save the current tick time, so we can restart
> -	 * the scheduler tick in nohz_restart_sched_tick().
> +	 * tick_nohz_stop_sched_tick() can be called several times before

s/tick_nohz_stop_sched_tick/tick_nohz_stop_tick

Because in the case of nohz_full it's indeed true. But idle behaves the same
even though it uses another function (tick_nohz_idle_stop_tick()).

More generally tick_nohz_stop_tick() covers both idle and nohz_full case
and behaves as described.

I guess at some point we should rename tick_nohz_stop_sched_tick() to
tick_nohz_full_stop_tick() to avoid such confusion.

Thanks.

> +	 * tick_nohz_restart_sched_tick() is called. This happens when
> +	 * interrupts arrive which do not cause a reschedule. In the first call
> +	 * we save the current tick time, so we can restart the scheduler tick
> +	 * in tick_nohz_restart_sched_tick().
>  	 */
>  	if (!ts->tick_stopped) {
>  		calc_load_nohz_start();
> -- 
> 2.39.2
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ