[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <c8bbb32d-5fc5-4682-a92c-e5e102fa0866@redhat.com>
Date: Wed, 10 Jan 2024 16:15:38 +0100
From: Danilo Krummrich <dakr@...hat.com>
To: yang.guang5@....com.cn
Cc: cgel.zte@...il.com, linux-kernel@...r.kernel.org,
dri-devel@...ts.freedesktop.org, chen.haonan2@....com.cn,
bskeggs@...hat.com, jiang.xuexin@....com.cn, nouveau@...ts.freedesktop.org,
keescook@...omium.org, kherbst@...hat.com
Subject: Re: [PATCH linux-next v2] drm/nouveau/disp: switch to use kmemdup()
helper
On 1/9/24 07:24, yang.guang5@....com.cn wrote:
> From: Chen Haonan <chen.haonan2@....com.cn>
>
> Use kmemdup() helper instead of open-coding to
> simplify the code.
>
> Signed-off-by: Chen Haonan <chen.haonan2@....com.cn>
> Reviewed-by: Yang Guang <yang.guang5@....com.cn>
Applied to drm-misc-next, thanks!
> ---
> drivers/gpu/drm/nouveau/nvif/outp.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/nouveau/nvif/outp.c b/drivers/gpu/drm/nouveau/nvif/outp.c
> index 5d3190c05250..6daeb7f0b09b 100644
> --- a/drivers/gpu/drm/nouveau/nvif/outp.c
> +++ b/drivers/gpu/drm/nouveau/nvif/outp.c
> @@ -452,13 +452,12 @@ nvif_outp_edid_get(struct nvif_outp *outp, u8 **pedid)
> if (ret)
> goto done;
>
> - *pedid = kmalloc(args->size, GFP_KERNEL);
> + *pedid = kmemdup(args->data, args->size, GFP_KERNEL);
> if (!*pedid) {
> ret = -ENOMEM;
> goto done;
> }
>
> - memcpy(*pedid, args->data, args->size);
> ret = args->size;
> done:
> kfree(args);
Powered by blists - more mailing lists