[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c21377fb-da4c-4cdb-994c-e469d4cb1e46@linux.intel.com>
Date: Mon, 22 Jan 2024 12:51:03 +0100
From: Amadeusz Sławiński
<amadeuszx.slawinski@...ux.intel.com>
To: Rui Salvaterra <rsalvaterra@...il.com>, tiwai@...e.com
Cc: linux-sound@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/2] ALSA: hda: Replace numeric device IDs with constant
values
On 1/22/2024 12:45 PM, Rui Salvaterra wrote:
> We have self-explanatory constants for Intel HDA devices, let's use them instead
> of magic numbers and code comments.
>
> Signed-off-by: Rui Salvaterra <rsalvaterra@...il.com>
> ---
> sound/pci/hda/hda_intel.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/sound/pci/hda/hda_intel.c b/sound/pci/hda/hda_intel.c
> index 2276adc84478..66f013ee160d 100644
> --- a/sound/pci/hda/hda_intel.c
> +++ b/sound/pci/hda/hda_intel.c
> @@ -1729,8 +1729,8 @@ static int default_bdl_pos_adj(struct azx *chip)
> /* some exceptions: Atoms seem problematic with value 1 */
> if (chip->pci->vendor == PCI_VENDOR_ID_INTEL) {
> switch (chip->pci->device) {
> - case 0x0f04: /* Baytrail */
> - case 0x2284: /* Braswell */
> + case PCI_DEVICE_ID_INTEL_HDA_BYT:
> + case PCI_DEVICE_ID_INTEL_HDA_BSW:
> return 32;
> }
> }
Reviewed-by: Amadeusz Sławiński <amadeuszx.slawinski@...ux.intel.com>
Powered by blists - more mailing lists