[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0f7bcdda163b25cb28ee0409b55f3d69f0f896ea.camel@physik.fu-berlin.de>
Date: Tue, 23 Jan 2024 08:31:34 +0100
From: John Paul Adrian Glaubitz <glaubitz@...sik.fu-berlin.de>
To: Kees Cook <keescook@...omium.org>, linux-hardening@...r.kernel.org
Cc: Yoshinori Sato <ysato@...rs.sourceforge.jp>, Rich Felker
<dalias@...c.org>, linux-sh@...r.kernel.org, "Gustavo A. R. Silva"
<gustavoars@...nel.org>, Bill Wendling <morbo@...gle.com>, Justin Stitt
<justinstitt@...gle.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 73/82] sh: Refactor intentional wrap-around test
Hello Kees,
On Mon, 2024-01-22 at 16:27 -0800, Kees Cook wrote:
> In an effort to separate intentional arithmetic wrap-around from
> unexpected wrap-around, we need to refactor places that depend on this
> kind of math. One of the most common code patterns of this is:
>
> VAR + value < VAR
>
> Notably, this is considered "undefined behavior" for signed and pointer
> types, which the kernel works around by using the -fno-strict-overflow
> option in the build[1] (which used to just be -fwrapv). Regardless, we
> want to get the kernel source to the position where we can meaningfully
> instrument arithmetic wrap-around conditions and catch them when they
> are unexpected, regardless of whether they are signed[2], unsigned[3],
> or pointer[4] types.
>
> Refactor open-coded wrap-around addition test to use add_would_overflow().
> This paves the way to enabling the wrap-around sanitizers in the future.
>
> Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1]
> Link: https://github.com/KSPP/linux/issues/26 [2]
> Link: https://github.com/KSPP/linux/issues/27 [3]
> Link: https://github.com/KSPP/linux/issues/344 [4]
> Cc: Yoshinori Sato <ysato@...rs.sourceforge.jp>
> Cc: Rich Felker <dalias@...c.org>
> Cc: John Paul Adrian Glaubitz <glaubitz@...sik.fu-berlin.de>
> Cc: linux-sh@...r.kernel.org
> Signed-off-by: Kees Cook <keescook@...omium.org>
> ---
> arch/sh/kernel/sys_sh.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/sh/kernel/sys_sh.c b/arch/sh/kernel/sys_sh.c
> index a5a7b33ed81a..e390caeb8c00 100644
> --- a/arch/sh/kernel/sys_sh.c
> +++ b/arch/sh/kernel/sys_sh.c
> @@ -66,7 +66,7 @@ asmlinkage int sys_cacheflush(unsigned long addr, unsigned long len, int op)
> * Verify that the specified address region actually belongs
> * to this process.
> */
> - if (addr + len < addr)
> + if (add_would_overflow(addr, len))
> return -EFAULT;
>
> mmap_read_lock(current->mm);
Sounds like a very sensible change to me.
Acked-by: John Paul Adrian Glaubitz <glaubitz@...sik.fu-berlin.de>
Adrian
--
.''`. John Paul Adrian Glaubitz
: :' : Debian Developer
`. `' Physicist
`- GPG: 62FF 8A75 84E0 2956 9546 0006 7426 3B37 F5B5 F913
Powered by blists - more mailing lists