[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1b25b492-b9e7-4411-90d1-463d44084043@oracle.com>
Date: Mon, 5 Feb 2024 14:28:13 +0200
From: Mihai Carabas <mihai.carabas@...cle.com>
To: Will Deacon <will@...nel.org>
Cc: linux-arm-kernel@...ts.infradead.org, kvm@...r.kernel.org,
linux-pm@...r.kernel.org, linux-kernel@...r.kernel.org,
catalin.marinas@....com, tglx@...utronix.de, mingo@...hat.com,
bp@...en8.de, x86@...nel.org, hpa@...or.com, pbonzini@...hat.com,
wanpengli@...cent.com, vkuznets@...hat.com, rafael@...nel.org,
daniel.lezcano@...aro.org, akpm@...ux-foundation.org, pmladek@...e.com,
peterz@...radead.org, dianders@...omium.org, npiggin@...il.com,
rick.p.edgecombe@...el.com, joao.m.martins@...cle.com,
juerg.haefliger@...onical.com, mic@...ikod.net, arnd@...db.de,
ankur.a.arora@...cle.com
Subject: Re: [PATCH 7/7] cpuidle/poll_state: replace cpu_relax with
smp_cond_load_relaxed
>>>> cpu_relax on ARM64 does a simple "yield". Thus we replace it with
>>>> smp_cond_load_relaxed which basically does a "wfe".
>>>>
>>>> Suggested-by: Peter Zijlstra <peterz@...radead.org>
>>>> Signed-off-by: Mihai Carabas <mihai.carabas@...cle.com>
>>>> ---
>>>> drivers/cpuidle/poll_state.c | 14 +++++++++-----
>>>> 1 file changed, 9 insertions(+), 5 deletions(-)
>>>>
>>>> diff --git a/drivers/cpuidle/poll_state.c b/drivers/cpuidle/poll_state.c
>>>> index 9b6d90a72601..440cd713e39a 100644
>>>> --- a/drivers/cpuidle/poll_state.c
>>>> +++ b/drivers/cpuidle/poll_state.c
>>>> @@ -26,12 +26,16 @@ static int __cpuidle poll_idle(struct cpuidle_device *dev,
>>>> limit = cpuidle_poll_time(drv, dev);
>>>> - while (!need_resched()) {
>>>> - cpu_relax();
>>>> - if (loop_count++ < POLL_IDLE_RELAX_COUNT)
>>>> - continue;
>>>> -
>>>> + for (;;) {
>>>> loop_count = 0;
>>>> +
>>>> + smp_cond_load_relaxed(¤t_thread_info()->flags,
>>>> + (VAL & _TIF_NEED_RESCHED) ||
>>>> + (loop_count++ >= POLL_IDLE_RELAX_COUNT));
>>>> +
>>>> + if (loop_count < POLL_IDLE_RELAX_COUNT)
>>>> + break;
>>>> +
>>>> if (local_clock_noinstr() - time_start > limit) {
>>>> dev->poll_time_limit = true;
>>>> break;
>>> Doesn't this make ARCH_HAS_CPU_RELAX a complete misnomer?
>> This controls the build of poll_state.c and the generic definition of
>> smp_cond_load_relaxed (used by x86) is using cpu_relax(). Do you propose
>> other approach here?
> Give it a better name? Having ARCH_HAS_CPU_RELAX control a piece of code
> that doesn't use cpu_relax() doesn't make sense to me.
The generic code for smp_cond_load_relaxed is using cpu_relax and this
one is used on x86 - so ARCH_HAS_CPU_RELAX is a prerequisite on x86 when
using haltpoll. Only on ARM64 this is overwritten. Moreover
ARCH_HAS_CPU_RELAX is controlling the function definition for
cpuidle_poll_state_init (this is how it was originally designed).
Thanks,
Mihai
Powered by blists - more mailing lists