[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240205142613.23914-1-fabio.maria.de.francesco@linux.intel.com>
Date: Mon, 5 Feb 2024 15:26:11 +0100
From: "Fabio M. De Francesco" <fabio.maria.de.francesco@...ux.intel.com>
To: Peter Zijlstra <peterz@...radead.org>,
Dan Williams <dan.j.williams@...el.com>,
linux-kernel@...r.kernel.org
Cc: linux-cxl@...r.kernel.org,
Ingo Molnar <mingo@...nel.org>,
Jonathan Cameron <Jonathan.Cameron@...wei.com>,
"Fabio M. De Francesco" <fabio.maria.de.francesco@...ux.intel.com>,
Ira Weiny <ira.weiny@...el.com>
Subject: [PATCH 0/2 v2] Add cond_guard() to conditional guards
Add cond_guard() macro to conditional guards and use it to replace an
open-coded up_read() in show_targetN() and remove a block marked by an
'out' label.
Cc: Peter Zijlstra <peterz@...radead.org>
Cc: Jonathan Cameron <Jonathan.Cameron@...wei.com>
Suggested-by: Dan Williams <dan.j.williams@...el.com>
Suggested-by: Ira Weiny <ira.weiny@...el.com>
Signed-off-by: Fabio M. De Francesco <fabio.maria.de.francesco@...ux.intel.com>
---
Changes from RFC v4:
Changed the interface of cond_guard() to take a variable to store
a return code, the succes code and failure code, to enable a
later check of the returned code in that variable.
Changes from RFC v5:
Changed the interface of cond_guard() to take one or more statements
in its second argument to conform to Dan's final suggestion
(thanks).
Changes from v1:
Fixed a grammar error in the commit message of 1/2; replaced the
name of the second argument of cond_guard() with '_fail'
according to Jonathan's comments (thanks).
Fabio M. De Francesco (2):
cleanup: Add cond_guard() to conditional guards
cxl/region: Use cond_guard() in show_targetN()
drivers/cxl/core/region.c | 16 ++++------------
include/linux/cleanup.h | 14 ++++++++++++++
2 files changed, 18 insertions(+), 12 deletions(-)
--
2.43.0
Powered by blists - more mailing lists