[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <3b1b5028-531f-49d4-a59e-cc39868719cb@broadcom.com>
Date: Fri, 9 Feb 2024 17:19:55 -0800
From: Florian Fainelli <florian.fainelli@...adcom.com>
To: Erick Archer <erick.archer@....com>, Thomas Gleixner
<tglx@...utronix.de>, "Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc: linux-mips@...r.kernel.org, linux-kernel@...r.kernel.org,
Broadcom internal kernel review list
<bcm-kernel-feedback-list@...adcom.com>, linux-hardening@...r.kernel.org
Subject: Re: [PATCH] irqchip/bcm-6345-l1: Prefer struct_size over open coded
arithmetic
On 2/9/2024 10:16 AM, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> As the cpu variable is a pointer to "struct bcm6345_l1_cpu" and this
> structure ends in a flexible array:
>
> struct bcm6345_l1_cpu {
> [...]
> u32 enable_cache[];
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the argument "size + count * size" in the
> kzalloc() function.
>
> This way, the code is more readable and more safer.
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162 [2]
> Signed-off-by: Erick Archer <erick.archer@....com>
Reviewed-by: Florian Fainelli <florian.fainelli@...adcom.com>
--
Florian
Download attachment "smime.p7s" of type "application/pkcs7-signature" (4221 bytes)
Powered by blists - more mailing lists