[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <170781821908.398.371290728146239013.tip-bot2@tip-bot2>
Date: Tue, 13 Feb 2024 09:56:59 -0000
From: "tip-bot2 for Erick Archer" <tip-bot2@...utronix.de>
To: linux-tip-commits@...r.kernel.org
Cc: Erick Archer <erick.archer@....com>, Thomas Gleixner <tglx@...utronix.de>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
Kees Cook <keescook@...omium.org>,
Florian Fainelli <florian.fainelli@...adcom.com>, x86@...nel.org,
linux-kernel@...r.kernel.org, maz@...nel.org
Subject: [tip: irq/core] irqchip/bcm-6345-l1: Prefer struct_size)_ over open
coded arithmetic
The following commit has been merged into the irq/core branch of tip:
Commit-ID: 004c7a6bf43edbd4b092fb6ebba8991d56bc3428
Gitweb: https://git.kernel.org/tip/004c7a6bf43edbd4b092fb6ebba8991d56bc3428
Author: Erick Archer <erick.archer@....com>
AuthorDate: Fri, 09 Feb 2024 19:16:00 +01:00
Committer: Thomas Gleixner <tglx@...utronix.de>
CommitterDate: Tue, 13 Feb 2024 10:53:15 +01:00
irqchip/bcm-6345-l1: Prefer struct_size)_ over open coded arithmetic
This is an effort to get rid of all multiplications from allocation
functions in order to prevent integer overflows.
The cpu variable is a pointer to "struct bcm6345_l1_cpu" and this structure
ends in a flexible array:
struct bcm6345_l1_cpu {
[...]
u32 enable_cache[];
};
The preferred way in the kernel is to use the struct_size() helper to do
the arithmetic instead of the argument "size + count * size" in the
kzalloc() function.
This way, the code is more readable and safer.
Signed-off-by: Erick Archer <erick.archer@....com>
Signed-off-by: Thomas Gleixner <tglx@...utronix.de>
Reviewed-by: Gustavo A. R. Silva <gustavoars@...nel.org>
Reviewed-by: Kees Cook <keescook@...omium.org>
Reviewed-by: Florian Fainelli <florian.fainelli@...adcom.com>
Link: https://lore.kernel.org/r/20240209181600.9472-1-erick.archer@gmx.com
Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
Link: https://github.com/KSPP/linux/issues/162 [2]
---
drivers/irqchip/irq-bcm6345-l1.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/irqchip/irq-bcm6345-l1.c b/drivers/irqchip/irq-bcm6345-l1.c
index 9745a11..eb02d20 100644
--- a/drivers/irqchip/irq-bcm6345-l1.c
+++ b/drivers/irqchip/irq-bcm6345-l1.c
@@ -242,7 +242,7 @@ static int __init bcm6345_l1_init_one(struct device_node *dn,
else if (intc->n_words != n_words)
return -EINVAL;
- cpu = intc->cpus[idx] = kzalloc(sizeof(*cpu) + n_words * sizeof(u32),
+ cpu = intc->cpus[idx] = kzalloc(struct_size(cpu, enable_cache, n_words),
GFP_KERNEL);
if (!cpu)
return -ENOMEM;
Powered by blists - more mailing lists