[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8e4c2001-9fac-48a4-a177-dd6472eb3643@intel.com>
Date: Fri, 23 Feb 2024 08:27:34 -0800
From: Dave Hansen <dave.hansen@...el.com>
To: Dongli Zhang <dongli.zhang@...cle.com>, x86@...nel.org
Cc: tglx@...utronix.de, mingo@...hat.com, bp@...en8.de,
dave.hansen@...ux.intel.com, hpa@...or.com, linux-kernel@...r.kernel.org,
joe.jin@...cle.com
Subject: Re: [PATCH 1/1] x86/split_lock: add the source of exception to
warning logs
On 2/23/24 01:47, Dongli Zhang wrote:
> @@ -1194,11 +1195,11 @@ static void split_lock_warn(unsigned long ip)
> bool handle_guest_split_lock(unsigned long ip)
> {
> if (sld_state == sld_warn) {
> - split_lock_warn(ip);
> + split_lock_warn(ip, true);
> return true;
> }
I really despise random true/falses getting passed to functions.
Wouldn't this be a lot easier to read if you just passed the string in:
split_lock_warn(ip, "guest");
rather than bools plus the ternary form dance?
Powered by blists - more mailing lists