lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Wed, 28 Feb 2024 16:44:20 -0500
From: Johannes Weiner <hannes@...xchg.org>
To: Byungchul Park <byungchul@...com>
Cc: akpm@...ux-foundation.org, linux-kernel@...r.kernel.org,
	linux-mm@...ck.org, kernel_team@...ynix.com
Subject: Re: [PATCH] mm/vmscan: simplify the calculation of fractions for
 SCAN_FRACT

On Wed, Feb 28, 2024 at 10:55:00AM +0900, Byungchul Park wrote:
> The current way to calculate fractions for SACN_FRACT is little readable
> and more complicated than it should be.  It also performs unnecessary
> division and adjustment to avoid zero operands.  Prune away by
> multiplying the fractions by 'anon_cost * file_cost / (3 * total_cost)':
> 
> where:
>    total_cost = sc->anon_cost + sc->file_cost
>    anon_cost = total_cost + sc->anon_cost
>    file_cost = total_cost + sc->file_cost
> 
> before:
>    fraction[0] = swappiness * 3 * total_cost / anon_cost
>    fraction[1] = (200 - swappiness) * 3 * total_cost / file_cost
> 
> after:
>    fraction[0] = swappiness * file_cost
>    fraction[1] = (200 - swappiness) * anon_cost
> 
> Worth noting that this patch doesn't change the formula.
> 
> Signed-off-by: Byungchul Park <byungchul@...com>
> ---
>  mm/vmscan.c | 14 +++-----------
>  1 file changed, 3 insertions(+), 11 deletions(-)
> 
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index 4657440854db..7b33fcc1cbdc 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -2339,7 +2339,6 @@ static void get_scan_count(struct lruvec *lruvec, struct scan_control *sc,
>  	u64 fraction[ANON_AND_FILE];
>  	u64 denominator = 0;	/* gcc */
>  	enum scan_balance scan_balance;
> -	unsigned long ap, fp;
>  	enum lru_list lru;
>  
>  	/*
> @@ -2416,17 +2415,10 @@ static void get_scan_count(struct lruvec *lruvec, struct scan_control *sc,
>  	total_cost = sc->anon_cost + sc->file_cost;
>  	anon_cost = total_cost + sc->anon_cost;
>  	file_cost = total_cost + sc->file_cost;
> -	total_cost = anon_cost + file_cost;
>  
> -	ap = swappiness * (total_cost + 1);
> -	ap /= anon_cost + 1;
> -
> -	fp = (200 - swappiness) * (total_cost + 1);
> -	fp /= file_cost + 1;
> -
> -	fraction[0] = ap;
> -	fraction[1] = fp;
> -	denominator = ap + fp;
> +	fraction[0] = swappiness * file_cost;
> +	fraction[1] = (200 - swappiness) * anon_cost;

Unfortunately, I don't think that

anon = swappiness * file_cost
file = (200 - swappiness) * anon_cost

is more readable. Sure it's the same, but I think it's clearer to
actually see that `anon = total_cost / anon_cost` ratio in the code.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ