[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240402111414.871089-1-ikobh7@gmail.com>
Date: Tue, 2 Apr 2024 14:14:08 +0300
From: Shahar Avidar <ikobh7@...il.com>
To: gregkh@...uxfoundation.org,
hverkuil-cisco@...all.nl,
andriy.shevchenko@...ux.intel.com,
robh@...nel.org,
felixkimbu1@...il.com
Cc: linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org
Subject: [PATCH v2 0/6] staging: pi433: Remove duplicated code using the "goto" error recovery scheme.
This patchset improves readability & maintainability:
- Rename device related vars.
- Update pi433_receive param type.
- Remove duplicated code in pi433_init.
v2->v1:
Followed by Dan Carpenter's <dan.carpenter@...aro.org> comments:
- Remove empty "fail" goto tag.
- Reorder pi433 init & exit calls so they have reverse order.
- Add "unreg_spi_drv" goto tag.
- Check "debugfs_create_dir" return value.
- Update "if" statments for consistency.
- Rename pi433_init return var to the more common used "ret".
Shahar Avidar (6):
staging: pi433: Rename struct pi433_device buffer field to tx_buffer.
staging: pi433: Rename struct pi433_device instances to pi433.
staging: pi433: Replace pi433_receive param void type to struct
pi433_device.
staging: pi433: Rename "pi433_dev" of type "dev_t" to "pi433_devt"
staging: pi433: Remove duplicated code using the "goto" error recovery
scheme.
staging: pi433: Rename return value from "status" to "ret".
drivers/staging/pi433/pi433_if.c | 710 ++++++++++++++++---------------
1 file changed, 358 insertions(+), 352 deletions(-)
base-commit: 20952655235dd9b1447829591774f1d8561f7c6a
prerequisite-patch-id: 91943193af2fea74182be67fb583235a3fbeb77b
prerequisite-patch-id: 2cad031ba6a0782a67ab1645ff034a8be65c2e76
prerequisite-patch-id: 1a852ed8f9d133aec7c651fd9007e59e39c55fb7
--
2.34.1
Powered by blists - more mailing lists