lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Sat, 13 Apr 2024 10:54:37 -0700
From: Yury Norov <yury.norov@...il.com>
To: Dawei Li <dawei.li@...ngroup.cn>
Cc: tglx@...utronix.de, akpm@...ux-foundation.org, maz@...nel.org,
	florian.fainelli@...adcom.com, chenhuacai@...nel.org,
	jiaxun.yang@...goat.com, anup@...infault.org, palmer@...belt.com,
	samuel.holland@...ive.com, linux@...musvillemoes.dk,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH 6/6] irqchip/sifive-plic: Avoid explicit cpumask
 allocation on stack

On Fri, Apr 12, 2024 at 06:58:39PM +0800, Dawei Li wrote:
> In general it's preferable to avoid placing cpumasks on the stack, as
> for large values of NR_CPUS these can consume significant amounts of
> stack space and make stack overflows more likely.
> 
> Use cpumask_first_and_and() to avoid the need for a temporary cpumask on
> the stack.
> 
> Signed-off-by: Dawei Li <dawei.li@...ngroup.cn>
> ---
>  drivers/irqchip/irq-sifive-plic.c | 8 +++-----
>  1 file changed, 3 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/irqchip/irq-sifive-plic.c b/drivers/irqchip/irq-sifive-plic.c
> index f3d4cb9e34f7..bf5d2fc6396e 100644
> --- a/drivers/irqchip/irq-sifive-plic.c
> +++ b/drivers/irqchip/irq-sifive-plic.c
> @@ -164,15 +164,13 @@ static int plic_set_affinity(struct irq_data *d,
>  			     const struct cpumask *mask_val, bool force)
>  {
>  	unsigned int cpu;
> -	struct cpumask amask;
>  	struct plic_priv *priv = irq_data_get_irq_chip_data(d);
>  
> -	cpumask_and(&amask, &priv->lmask, mask_val);
> -
>  	if (force)
> -		cpu = cpumask_first(&amask);
> +		cpu = cpumask_first_and(&priv->lmask, mask_val);
>  	else
> -		cpu = cpumask_any_and(&amask, cpu_online_mask);
> +		cpu = cpumask_first_and_and(&priv->lmask, mask_val,
> +					    cpu_online_mask);

Don't need to split the line here. The new max length is 100 chars,
here's 85 when unsplit, and it hurts readability for nothing.

>  
>  	if (cpu >= nr_cpu_ids)
>  		return -EINVAL;
> -- 
> 2.27.0

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ