[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240425073709.379016-1-vincent.guittot@linaro.org>
Date: Thu, 25 Apr 2024 09:37:09 +0200
From: Vincent Guittot <vincent.guittot@...aro.org>
To: lkp@...el.com,
sudeep.holla@....com,
rafael@...nel.org,
mingo@...hat.com,
peterz@...radead.org,
lukasz.luba@....com,
gregkh@...uxfoundation.org,
linux-kernel@...r.kernel.org,
qyousef@...alina.io
Cc: Vincent Guittot <vincent.guittot@...aro.org>
Subject: [PATCH] arch/topology: Fix variable naming
Using hw_pressure for local variable is confusing in regard to the
per_cpu hw_pressure variable. Rename it to avoid confusion.
Reported-by: kernel test robot <lkp@...el.com>
Closes: https://lore.kernel.org/oe-kbuild-all/202404250740.VhQQoD7N-lkp@intel.com/
Signed-off-by: Vincent Guittot <vincent.guittot@...aro.org>
---
drivers/base/arch_topology.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/base/arch_topology.c b/drivers/base/arch_topology.c
index 0248912ff687..c66d070207a0 100644
--- a/drivers/base/arch_topology.c
+++ b/drivers/base/arch_topology.c
@@ -179,7 +179,7 @@ DEFINE_PER_CPU(unsigned long, hw_pressure);
void topology_update_hw_pressure(const struct cpumask *cpus,
unsigned long capped_freq)
{
- unsigned long max_capacity, capacity, hw_pressure;
+ unsigned long max_capacity, capacity, pressure;
u32 max_freq;
int cpu;
@@ -196,12 +196,12 @@ void topology_update_hw_pressure(const struct cpumask *cpus,
else
capacity = mult_frac(max_capacity, capped_freq, max_freq);
- hw_pressure = max_capacity - capacity;
+ pressure = max_capacity - capacity;
- trace_hw_pressure_update(cpu, hw_pressure);
+ trace_hw_pressure_update(cpu, pressure);
for_each_cpu(cpu, cpus)
- WRITE_ONCE(per_cpu(hw_pressure, cpu), hw_pressure);
+ WRITE_ONCE(per_cpu(hw_pressure, cpu), pressure);
}
EXPORT_SYMBOL_GPL(topology_update_hw_pressure);
--
2.34.1
Powered by blists - more mailing lists