[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240511201617.292811-1-sj@kernel.org>
Date: Sat, 11 May 2024 13:16:17 -0700
From: SeongJae Park <sj@...nel.org>
To: SeongJae Park <sj@...nel.org>
Cc: Honggyu Kim <honggyu.kim@...com>,
damon@...ts.linux.dev,
linux-mm@...ck.org,
akpm@...ux-foundation.org,
apopple@...dia.com,
baolin.wang@...ux.alibaba.com,
dave.jiang@...el.com,
hyeongtak.ji@...com,
kernel_team@...ynix.com,
linmiaohe@...wei.com,
linux-kernel@...r.kernel.org,
linux-trace-kernel@...r.kernel.org,
mathieu.desnoyers@...icios.com,
mhiramat@...nel.org,
rakie.kim@...com,
rostedt@...dmis.org,
surenb@...gle.com,
yangx.jy@...itsu.com,
ying.huang@...el.com,
ziy@...dia.com,
42.hyeyoo@...il.com,
art.jeongseob@...il.com
Subject: Re: [RFC PATCH v3 1/7] mm/damon/paddr: refactor DAMOS_PAGEOUT with migration_mode
On Fri, 5 Apr 2024 12:19:07 -0700 SeongJae Park <sj@...nel.org> wrote:
> On Fri, 5 Apr 2024 15:08:50 +0900 Honggyu Kim <honggyu.kim@...com> wrote:
>
> > This is a preparation patch that introduces migration modes.
> >
> > The damon_pa_pageout is renamed to damon_pa_migrate and it receives an
> > extra argument for migration_mode.
>
> I personally think keeping damon_pa_pageout() as is and adding a new function
> (damon_pa_migrate()) with some duplicated code is also ok, but this approach
> also looks fine to me. So I have no strong opinion here, but just letting you
> know I would have no objection at both approaches.
Meanwhile, we added one more logic in damon_pa_pageout() for doing page
idleness double check on its own[1]. It makes reusing damon_pa_pageout() for
multiple reason a bit complex. I think the complexity added a problem in this
patch that I also missed before due to the complexity. Show below comment in
line. Hence now I think it would be better to do the suggested way.
If we use the approach, this patch is no more necessary, and therefore can be
dropped.
[1] https://lore.kernel.org/20240426195247.100306-1-sj@kernel.org
Thanks,
SJ
[...]
>
> >
> > No functional changes applied.
> >
> > Signed-off-by: Honggyu Kim <honggyu.kim@...com>
> > ---
> > mm/damon/paddr.c | 18 +++++++++++++++---
> > 1 file changed, 15 insertions(+), 3 deletions(-)
> >
> > diff --git a/mm/damon/paddr.c b/mm/damon/paddr.c
> > index 081e2a325778..277a1c4d833c 100644
> > --- a/mm/damon/paddr.c
> > +++ b/mm/damon/paddr.c
> > @@ -224,7 +224,12 @@ static bool damos_pa_filter_out(struct damos *scheme, struct folio *folio)
> > return false;
> > }
> >
> > -static unsigned long damon_pa_pageout(struct damon_region *r, struct damos *s)
> > +enum migration_mode {
> > + MIG_PAGEOUT,
> > +};
>
> To avoid name conflicts, what about renaming to 'damos_migration_mode' and
> 'DAMOS_MIG_PAGEOUT'?
>
> > +
> > +static unsigned long damon_pa_migrate(struct damon_region *r, struct damos *s,
> > + enum migration_mode mm)
>
> My poor brain has a bit confused with the name. What about calling it 'mode'?
>
> > {
> > unsigned long addr, applied;
> > LIST_HEAD(folio_list);
> > @@ -249,7 +254,14 @@ static unsigned long damon_pa_pageout(struct damon_region *r, struct damos *s)
Before this line, damon_pa_pageout() calls folio_clear_referenced() and
folio_test_clear_young() for the folio, because this is pageout code. Changed
function, damon_pa_migrate() is not only for cold pages but general migrations.
Hence it should also be handled based on the migration mode, but not handled.
I think this problem came from the increased complexity of this function.
Hence I think it is better to keep damon_pa_pageout() as is and adding a new
function for migration.
Thanks,
SJ
[...]
Powered by blists - more mailing lists