[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8fd93c4e-3324-49b6-a77c-ea9986bc3033@web.de>
Date: Wed, 10 Jul 2024 22:09:04 +0200
From: Markus Elfring <Markus.Elfring@....de>
To: Vasiliy Kovalev <kovalev@...linux.org>, linux-fsdevel@...r.kernel.org,
lvc-patches@...uxtesting.org,
syzbot+d98fd19acd08b36ff422@...kaller.appspotmail.com
Cc: stable@...r.kernel.org, LKML <linux-kernel@...r.kernel.org>,
"Tigran A. Aivazian" <aivazian.tigran@...il.com>, dutyrok@...linux.org
Subject: Re: [PATCH fs/bfs 1/2] bfs: fix null-ptr-deref in bfs_move_block
> Add a check to ensure 'sb_getblk' did not return NULL before copying data.
Wording suggestion:
that a sb_getblk() call
How do you think about to use a summary phrase like
“Prevent null pointer dereference in bfs_move_block()”?
…
> +++ b/fs/bfs/file.c
> @@ -35,16 +35,22 @@ static int bfs_move_block(unsigned long from, unsigned long to,
> struct super_block *sb)
> {
> struct buffer_head *bh, *new;
> + int err;
Can a statement (like the following) become more appropriate for such
a function implementation?
int ret = 0;
Regards,
Markus
Powered by blists - more mailing lists